summaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/can.mk
diff options
context:
space:
mode:
authorJonas Gorski <jogo@openwrt.org>2015-06-22 12:27:59 +0000
committerJonas Gorski <jogo@openwrt.org>2015-06-22 12:27:59 +0000
commita0c49ef46f7caf5eb02c635d446218201008ecff (patch)
treea94180d50839c1587dfe845e8faf16405fab78ff /package/kernel/linux/modules/can.mk
parent518ab154e059c9f39684f8c78159c9caf333716b (diff)
downloadmaster-31e0f0ae-a0c49ef46f7caf5eb02c635d446218201008ecff.tar.gz
master-31e0f0ae-a0c49ef46f7caf5eb02c635d446218201008ecff.tar.bz2
master-31e0f0ae-a0c49ef46f7caf5eb02c635d446218201008ecff.zip
generic: add linux 4.1 support
Boot tested: http://pastebin.com/L6aAb9xj Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com> [jogo: update to 4.1 final add patches added since submission delete patches applied in later rcs restore commit messages in 220-gc-sections and 304-mips_disable_fpu fix 050-backport_netfilter_rtcache to match new API update inlined dma ops with upstream changes add missing config symbols enabled CONFIG_MULTIUSER update kmod defintions for 4.1 ] Signed-off-by: Jonas Gorski <jogo@openwrt.org> SVN-Revision: 46112
Diffstat (limited to 'package/kernel/linux/modules/can.mk')
-rw-r--r--package/kernel/linux/modules/can.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/kernel/linux/modules/can.mk b/package/kernel/linux/modules/can.mk
index 9245490a20..f9490b40d4 100644
--- a/package/kernel/linux/modules/can.mk
+++ b/package/kernel/linux/modules/can.mk
@@ -240,7 +240,7 @@ $(eval $(call KernelPackage,can-c-can))
define KernelPackage/can-c-can-platform
TITLE:=Platform Bus based BOSCH C_CAN/D_CAN driver
KCONFIG:=CONFIG_CAN_C_CAN_PLATFORM
- DEPENDS:=kmod-can-c-can
+ DEPENDS:=kmod-can-c-can +LINUX_4_1:kmod-regmap
FILES:=$(LINUX_DIR)/drivers/net/can/c_can/c_can_platform.ko
AUTOLOAD:=$(call AutoProbe,c_can_platform)
$(call AddDepends/can)