summaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/can.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2014-03-21 15:54:41 +0000
committerFelix Fietkau <nbd@openwrt.org>2014-03-21 15:54:41 +0000
commit5041b8e46cd92534190c02106f7c5625bb4fbc51 (patch)
treedc43a5ce051793be139cc2da40489c0117727440 /package/kernel/linux/modules/can.mk
parent04d99f29cfd2ce6a80e1480c24ed8e2733224366 (diff)
downloadmaster-31e0f0ae-5041b8e46cd92534190c02106f7c5625bb4fbc51.tar.gz
master-31e0f0ae-5041b8e46cd92534190c02106f7c5625bb4fbc51.tar.bz2
master-31e0f0ae-5041b8e46cd92534190c02106f7c5625bb4fbc51.zip
kernel: add can.ko to the kmod-can package.
Build all of the can support as modules, otherwise the kernel image is changed when a can kernel package is selected, because the can protocol is then built in into the kernel image. Signed-off-by: Jan Kardell <jan.kardell@telliq.com> SVN-Revision: 39989
Diffstat (limited to 'package/kernel/linux/modules/can.mk')
-rw-r--r--package/kernel/linux/modules/can.mk7
1 files changed, 4 insertions, 3 deletions
diff --git a/package/kernel/linux/modules/can.mk b/package/kernel/linux/modules/can.mk
index 39c1c969ad..ab7fcfa53a 100644
--- a/package/kernel/linux/modules/can.mk
+++ b/package/kernel/linux/modules/can.mk
@@ -11,7 +11,7 @@ define KernelPackage/can
SUBMENU:=$(CAN_MENU)
TITLE:=CAN bus support
KCONFIG:=\
- CONFIG_CAN=y \
+ CONFIG_CAN=m \
CONFIG_CAN_DEV \
CONFIG_CAN_CALC_BITTIMING=y \
CONFIG_CAN_LEDS=y \
@@ -29,8 +29,9 @@ define KernelPackage/can
CONFIG_CAN_SOFTING=n \
CONFIG_NET_EMATCH_CANID=n \
CONFIG_CAN_DEBUG_DEVICES=n
- FILES:=$(LINUX_DIR)/drivers/net/can/can-dev.ko
- AUTOLOAD:=$(call AutoProbe,can-dev)
+ FILES:=$(LINUX_DIR)/drivers/net/can/can-dev.ko \
+ $(LINUX_DIR)/net/can/can.ko
+ AUTOLOAD:=$(call AutoProbe,can can-dev)
endef
define KernelPackage/can/description