summaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/001-depends.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2013-07-21 11:55:30 +0000
committerFelix Fietkau <nbd@openwrt.org>2013-07-21 11:55:30 +0000
commit94439c2b5d797a1e18ae9ff81a76a8e53ce2fa09 (patch)
treeac52617d4248bc1c6267b252073f30decac690ae /package/kernel/linux/modules/001-depends.mk
parent8fc44d1f5f472d980f7209757bfc674d5b9da5a2 (diff)
downloadmaster-31e0f0ae-94439c2b5d797a1e18ae9ff81a76a8e53ce2fa09.tar.gz
master-31e0f0ae-94439c2b5d797a1e18ae9ff81a76a8e53ce2fa09.tar.bz2
master-31e0f0ae-94439c2b5d797a1e18ae9ff81a76a8e53ce2fa09.zip
kernel: add a new global config symbol for enabling rfkill support (can be enabled by default via target feature flag)
Signed-off-by: Felix Fietkau <nbd@openwrt.org> SVN-Revision: 37491
Diffstat (limited to 'package/kernel/linux/modules/001-depends.mk')
-rw-r--r--package/kernel/linux/modules/001-depends.mk7
1 files changed, 1 insertions, 6 deletions
diff --git a/package/kernel/linux/modules/001-depends.mk b/package/kernel/linux/modules/001-depends.mk
index ed894311cc..d0ad083662 100644
--- a/package/kernel/linux/modules/001-depends.mk
+++ b/package/kernel/linux/modules/001-depends.mk
@@ -22,13 +22,8 @@ define AddDepends/nls
DEPENDS+= +kmod-nls-base $(foreach cp,$(1),+kmod-nls-$(cp))
endef
-
-define SetDepends/rfkill
- DEPENDS:= @(TARGET_ar71xx||TARGET_brcm47xx||TARGET_s3c24xx||TARGET_x86||TARGET_gemini||TARGET_cns3xxx||TARGET_ixp4xx) $(1)
-endef
-
define AddDepends/rfkill
- DEPENDS+= +(TARGET_ar71xx||TARGET_brcm47xx||TARGET_s3c24xx||TARGET_x86||TARGET_cns3xxx||TARGET_ixp4xx):kmod-rfkill $(1)
+ DEPENDS+= +USE_RFKILL:kmod-rfkill $(1)
endef