summaryrefslogtreecommitdiffstats
path: root/package/kernel/lantiq
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2014-10-05 18:58:47 +0000
committerFelix Fietkau <nbd@openwrt.org>2014-10-05 18:58:47 +0000
commit8a450a93a59d06d401d4696737cbd13a783fbca7 (patch)
tree9e66396bb959256c6730c047ec6ec48182873b16 /package/kernel/lantiq
parentb6fb77ebfe3255f5515127614eefdcb78650efe2 (diff)
downloadmaster-31e0f0ae-8a450a93a59d06d401d4696737cbd13a783fbca7.tar.gz
master-31e0f0ae-8a450a93a59d06d401d4696737cbd13a783fbca7.tar.bz2
master-31e0f0ae-8a450a93a59d06d401d4696737cbd13a783fbca7.zip
lantiq: remove the useless ltqtapi.mk include file
Signed-off-by: Felix Fietkau <nbd@openwrt.org> SVN-Revision: 42778
Diffstat (limited to 'package/kernel/lantiq')
-rw-r--r--package/kernel/lantiq/ltq-tapi/Makefile3
-rw-r--r--package/kernel/lantiq/ltq-vmmc/Makefile3
2 files changed, 2 insertions, 4 deletions
diff --git a/package/kernel/lantiq/ltq-tapi/Makefile b/package/kernel/lantiq/ltq-tapi/Makefile
index e0742e63e5..0b4301c50e 100644
--- a/package/kernel/lantiq/ltq-tapi/Makefile
+++ b/package/kernel/lantiq/ltq-tapi/Makefile
@@ -20,14 +20,13 @@ PKG_MAINTAINER:=John Crispin <blogic@openwrt.org>
PKG_USE_MIPS16:=0
PKG_CHECK_FORMAT_SECURITY:=0
-include $(INCLUDE_DIR)/ltqtapi.mk
include $(INCLUDE_DIR)/package.mk
define KernelPackage/ltq-tapi
SUBMENU:=Voice over IP
TITLE:=Lantiq TAPI subsystem
URL:=http://www.lantiq.com/
- DEPENDS:=$(LTQ_TAPI_TARGET) +kmod-ltq-ifxos
+ DEPENDS:=@(TARGET_lantiq_falcon||TARGET_lantiq_xway) +kmod-ltq-ifxos
FILES:=$(PKG_BUILD_DIR)/src/drv_tapi.ko
AUTOLOAD:=$(call AutoLoad,20,drv_tapi)
endef
diff --git a/package/kernel/lantiq/ltq-vmmc/Makefile b/package/kernel/lantiq/ltq-vmmc/Makefile
index d25f3e14b2..df97fa19ee 100644
--- a/package/kernel/lantiq/ltq-vmmc/Makefile
+++ b/package/kernel/lantiq/ltq-vmmc/Makefile
@@ -20,14 +20,13 @@ PKG_MAINTAINER:=John Crispin <blogic@openwrt.org>
PKG_USE_MIPS16:=0
PKG_CHECK_FORMAT_SECURITY:=0
-include $(INCLUDE_DIR)/ltqtapi.mk
include $(INCLUDE_DIR)/package.mk
define KernelPackage/ltq-vmmc
SUBMENU:=Voice over IP
TITLE:=TAPI LL driver for Voice Macro
URL:=http://www.lantiq.com/
- DEPENDS:=$(LTQ_TAPI_TARGET) +kmod-ltq-tapi
+ DEPENDS:=@(TARGET_lantiq_falcon||TARGET_lantiq_xway) +kmod-ltq-tapi
FILES:=$(PKG_BUILD_DIR)/src/drv_vmmc.ko
AUTOLOAD:=$(call AutoProbe,drv_vmmc)
endef