summaryrefslogtreecommitdiffstats
path: root/package/kernel/lantiq/ltq-ifxos/Makefile
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2015-11-24 20:39:59 +0000
committerJohn Crispin <john@openwrt.org>2015-11-24 20:39:59 +0000
commitc4bbe3698db51ebacc5d36181fd25c584cf1d061 (patch)
treea9170d5262bb70b3fa2a67629a22b18f8e004e37 /package/kernel/lantiq/ltq-ifxos/Makefile
parentf5970b94720ce7016979ac2fd3fef50f23994740 (diff)
downloadmaster-31e0f0ae-c4bbe3698db51ebacc5d36181fd25c584cf1d061.tar.gz
master-31e0f0ae-c4bbe3698db51ebacc5d36181fd25c584cf1d061.tar.bz2
master-31e0f0ae-c4bbe3698db51ebacc5d36181fd25c584cf1d061.zip
lantiq: ltq-ifxos: fix build warnings
This makes the build script use the same configure options as used by Lantiq UGW and fixes some warnings and cleans up some of the patches. Signed-off-by: Hauke Mehrtens <hauke.mehrtens@lantiq.com> SVN-Revision: 47630
Diffstat (limited to 'package/kernel/lantiq/ltq-ifxos/Makefile')
-rw-r--r--package/kernel/lantiq/ltq-ifxos/Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/package/kernel/lantiq/ltq-ifxos/Makefile b/package/kernel/lantiq/ltq-ifxos/Makefile
index 9919a9b088..70fb4da1e0 100644
--- a/package/kernel/lantiq/ltq-ifxos/Makefile
+++ b/package/kernel/lantiq/ltq-ifxos/Makefile
@@ -8,7 +8,7 @@ include $(INCLUDE_DIR)/kernel.mk
PKG_NAME:=lib_ifxos
PKG_VERSION:=1.5.19
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_BUILD_DIR:=$(KERNEL_BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
PKG_SOURCE_URL:=https://github.com/xdarklight/$(PKG_NAME)/archive/v$(PKG_VERSION)
@@ -31,12 +31,14 @@ define KernelPackage/ltq-ifxos
AUTOLOAD:=$(call AutoLoad,10,drv_ifxos)
endef
+MAKE_FLAGS+=-s
+
CONFIGURE_ARGS += \
ARCH=$(LINUX_KARCH) \
--enable-linux-26 \
--enable-kernelbuild="$(LINUX_DIR)" \
--enable-kernelincl="$(LINUX_DIR)/include" \
- --enable-add_drv_cflags="-fno-pic -mno-abicalls -mlong-calls -G 0"
+ --with-kernel-module
ifdef CONFIG_TARGET_lantiq
define Build/InstallDev