summaryrefslogtreecommitdiffstats
path: root/package/kernel/acx-mac80211
diff options
context:
space:
mode:
authorJonas Gorski <jogo@openwrt.org>2014-12-11 19:35:36 +0000
committerJonas Gorski <jogo@openwrt.org>2014-12-11 19:35:36 +0000
commit7eddcb14ff9496fe041e05832ba340e26a9cbaaf (patch)
tree8e298ea3e588a9de01b7cbe45686eb1d7d3df865 /package/kernel/acx-mac80211
parent6f4656c19b43b3cd00f724aa03cf826941fbccfb (diff)
downloadmaster-31e0f0ae-7eddcb14ff9496fe041e05832ba340e26a9cbaaf.tar.gz
master-31e0f0ae-7eddcb14ff9496fe041e05832ba340e26a9cbaaf.tar.bz2
master-31e0f0ae-7eddcb14ff9496fe041e05832ba340e26a9cbaaf.zip
kernel/acx-mac80211: fix autoloading on boot
The kernel build system cannot track dependencies of out-of-tree modules, making the buildsystem fail to load mac80211. Add mac80211 as an explicit load to ensure all required modules are loaded. Fixes #16522. Signed-off-by: Jonas Gorski <jogo@openwrt.org> SVN-Revision: 43631
Diffstat (limited to 'package/kernel/acx-mac80211')
-rw-r--r--package/kernel/acx-mac80211/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/kernel/acx-mac80211/Makefile b/package/kernel/acx-mac80211/Makefile
index 16f6f5d06e..dfb73f71b8 100644
--- a/package/kernel/acx-mac80211/Makefile
+++ b/package/kernel/acx-mac80211/Makefile
@@ -32,7 +32,7 @@ define KernelPackage/acx-mac80211
TITLE:=ACX1xx mac80211 driver
DEPENDS:=@(PCI_SUPPORT||TARGET_ar7) @mipsel +kmod-mac80211
FILES:=$(PKG_BUILD_DIR)/acx-mac80211.ko
- AUTOLOAD:=$(call AutoLoad,50,acx-mac80211)
+ AUTOLOAD:=$(call AutoLoad,50,mac80211 acx-mac80211)
MAINTAINER:=Florian Fainelli <florian@openwrt.org>
MENU:=1
endef