summaryrefslogtreecommitdiffstats
path: root/package/jshn/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2011-08-11 22:09:11 +0000
committerFelix Fietkau <nbd@openwrt.org>2011-08-11 22:09:11 +0000
commit5e4563221a3af6ee81a0746e4e002f9607c8bec2 (patch)
treebdb9bc92ca2065c6bfc9a717b16d21face24373f /package/jshn/Makefile
parent09bc84f55bfb5fa17f3c0fdda36054f8fe4d4962 (diff)
downloadmaster-31e0f0ae-5e4563221a3af6ee81a0746e4e002f9607c8bec2.tar.gz
master-31e0f0ae-5e4563221a3af6ee81a0746e4e002f9607c8bec2.tar.bz2
master-31e0f0ae-5e4563221a3af6ee81a0746e4e002f9607c8bec2.zip
update libubox and ubus to latest, libubox now includes jshn
SVN-Revision: 27963
Diffstat (limited to 'package/jshn/Makefile')
-rw-r--r--package/jshn/Makefile33
1 files changed, 0 insertions, 33 deletions
diff --git a/package/jshn/Makefile b/package/jshn/Makefile
deleted file mode 100644
index 763871a95e..0000000000
--- a/package/jshn/Makefile
+++ /dev/null
@@ -1,33 +0,0 @@
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=jshn
-PKG_VERSION:=0.1
-PKG_RELEASE=1
-
-include $(INCLUDE_DIR)/package.mk
-
-define Package/jshn
- SECTION:=utils
- CATEGORY:=Utilities
- DEPENDS:=+libjson
- TITLE:=JSON SHell Notation
-endef
-
-define Package/jshn/description
- Library for parsing and generating JSON from shell scripts
-endef
-
-PKG_BUILD_DEPENDS += libubox
-TARGET_CFLAGS += -I$(STAGING_DIR)/usr/include --std=gnu99
-
-define Build/Compile
- $(TARGET_CC) $(TARGET_CFLAGS) -o $(PKG_BUILD_DIR)/jshn src/jshn.c $(TARGET_LDFLAGS) -ljson
-endef
-
-define Package/jshn/install
- $(INSTALL_DIR) $(1)/bin $(1)/lib/functions
- $(INSTALL_BIN) $(PKG_BUILD_DIR)/jshn $(1)/bin
- $(INSTALL_DATA) ./files/jshn.sh $(1)/lib/functions
-endef
-
-$(eval $(call BuildPackage,jshn))