summaryrefslogtreecommitdiffstats
path: root/package/iptables
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2011-05-24 08:14:29 +0000
committerJo-Philipp Wich <jow@openwrt.org>2011-05-24 08:14:29 +0000
commitbe906f6be55b890edc766a8826c8cc56f0732d8d (patch)
tree9ef3360c258ca0a0f852f4e87a81eed250b466f5 /package/iptables
parenta12a8271a7de80a6080ab3eaf0ddcf067249596c (diff)
downloadmaster-31e0f0ae-be906f6be55b890edc766a8826c8cc56f0732d8d.tar.gz
master-31e0f0ae-be906f6be55b890edc766a8826c8cc56f0732d8d.tar.bz2
master-31e0f0ae-be906f6be55b890edc766a8826c8cc56f0732d8d.zip
package u32 match and TEE target, patches by Maxim Uvarov
SVN-Revision: 26977
Diffstat (limited to 'package/iptables')
-rw-r--r--package/iptables/Makefile23
1 files changed, 23 insertions, 0 deletions
diff --git a/package/iptables/Makefile b/package/iptables/Makefile
index f0f96f0351..61739d3551 100644
--- a/package/iptables/Makefile
+++ b/package/iptables/Makefile
@@ -229,6 +229,27 @@ Includes:
- libxt_TPROXY
endef
+define Package/iptables-mod-tee
+$(call Package/iptables/Module, +kmod-ipt-tee)
+ TITLE:=TEE iptables extensions
+endef
+
+define Package/iptables-mod-tee/description
+TEE iptables extensions.
+Includes:
+- libxt_TEE
+endef
+
+define Package/iptables-mod-u32
+$(call Package/iptables/Module, +kmod-ipt-u32)
+ TITLE:=U32 iptables extensions
+endef
+
+define Package/iptables-mod-u32/description
+U32 iptables extensions.
+Includes:
+- libxt_u32
+endef
define Package/iptables-utils
$(call Package/iptables/Module, )
@@ -424,6 +445,8 @@ $(eval $(call BuildPlugin,iptables-mod-iprange,$(IPT_IPRANGE-m)))
$(eval $(call BuildPlugin,iptables-mod-ulog,$(IPT_ULOG-m)))
$(eval $(call BuildPlugin,iptables-mod-hashlimit,$(IPT_HASHLIMIT-m)))
$(eval $(call BuildPlugin,iptables-mod-tproxy,$(IPT_TPROXY-m)))
+$(eval $(call BuildPlugin,iptables-mod-tee,$(IPT_TEE-m)))
+$(eval $(call BuildPlugin,iptables-mod-u32,$(IPT_U32-m)))
$(eval $(call BuildPackage,ip6tables))
$(eval $(call BuildPackage,ip6tables-utils))
$(eval $(call BuildPackage,libiptc))