summaryrefslogtreecommitdiffstats
path: root/package/iptables
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2009-01-08 02:18:45 +0000
committerNicolas Thill <nico@openwrt.org>2009-01-08 02:18:45 +0000
commit704402ab56cc5a6cc971418ed75bd416d6ca85e1 (patch)
treef5631f31edad92e56f5e41d99aaacad40914bfd2 /package/iptables
parenta3edea1b9136b05edfed95b58ba33a9ff46b6587 (diff)
downloadmaster-31e0f0ae-704402ab56cc5a6cc971418ed75bd416d6ca85e1.tar.gz
master-31e0f0ae-704402ab56cc5a6cc971418ed75bd416d6ca85e1.tar.bz2
master-31e0f0ae-704402ab56cc5a6cc971418ed75bd416d6ca85e1.zip
temp fix for iptables build failure after [13931]
SVN-Revision: 13932
Diffstat (limited to 'package/iptables')
-rw-r--r--package/iptables/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/package/iptables/Makefile b/package/iptables/Makefile
index 43a3cdf515..55ca0b370f 100644
--- a/package/iptables/Makefile
+++ b/package/iptables/Makefile
@@ -256,7 +256,10 @@ endif
TARGET_CPPFLAGS := -I$(PKG_BUILD_DIR)/include $(TARGET_CPPFLAGS)
TARGET_CFLAGS += $(FPIC)
-CONFIGURE_ARGS += --enable-devel --with-xtlibdir=/usr/lib/iptables
+CONFIGURE_ARGS += \
+ --enable-devel \
+ --with-kernel="$(LINUX_DIR)" \
+ --with-xtlibdir=/usr/lib/iptables
define Build/Compile
mkdir -p $(PKG_INSTALL_DIR)