summaryrefslogtreecommitdiffstats
path: root/package/iptables/Makefile
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2010-06-22 22:39:22 +0000
committerJo-Philipp Wich <jow@openwrt.org>2010-06-22 22:39:22 +0000
commit91468dcf4ff06a7d691f3dcbc63c152b669ac72b (patch)
treec8cc5e96d1292108714fcf1e282da2d4a6a3a2f8 /package/iptables/Makefile
parentded2b7765262a6a9903e7e31bf715625c6f83cd0 (diff)
downloadmaster-31e0f0ae-91468dcf4ff06a7d691f3dcbc63c152b669ac72b.tar.gz
master-31e0f0ae-91468dcf4ff06a7d691f3dcbc63c152b669ac72b.tar.bz2
master-31e0f0ae-91468dcf4ff06a7d691f3dcbc63c152b669ac72b.zip
package TPROXY target and module infrastructure
SVN-Revision: 21883
Diffstat (limited to 'package/iptables/Makefile')
-rw-r--r--package/iptables/Makefile14
1 files changed, 14 insertions, 0 deletions
diff --git a/package/iptables/Makefile b/package/iptables/Makefile
index d8698c5de6..b37a66fd3f 100644
--- a/package/iptables/Makefile
+++ b/package/iptables/Makefile
@@ -214,6 +214,19 @@ Includes:
- libipt_recent
endef
+define Package/iptables-mod-tproxy
+$(call Package/iptables/Module, +kmod-ipt-tproxy)
+ TITLE:=Transparent proxy iptables extensions
+endef
+
+define Package/iptables-mod-tproxy/description
+Transparent proxy iptables extensions.
+Includes:
+- libxt_socket
+- libxt_TPROXY
+endef
+
+
define Package/iptables-utils
$(call Package/iptables/Module, )
TITLE:=iptables save and restore utilities
@@ -380,6 +393,7 @@ $(eval $(call BuildPlugin,iptables-mod-nat,$(IPT_NAT-m)))
$(eval $(call BuildPlugin,iptables-mod-nat-extra,$(IPT_NAT_EXTRA-m)))
$(eval $(call BuildPlugin,iptables-mod-iprange,$(IPT_IPRANGE-m)))
$(eval $(call BuildPlugin,iptables-mod-ulog,$(IPT_ULOG-m)))
+$(eval $(call BuildPlugin,iptables-mod-tproxy,$(IPT_TPROXY-m)))
$(eval $(call BuildPackage,ip6tables))
$(eval $(call BuildPackage,ip6tables-utils))
$(eval $(call BuildPackage,libiptc))