summaryrefslogtreecommitdiffstats
path: root/package/iproute2/Makefile
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2012-04-16 15:04:42 +0000
committerJo-Philipp Wich <jow@openwrt.org>2012-04-16 15:04:42 +0000
commitf638b544f3b2ffe568f581f0225760ef6cc31d92 (patch)
treebdd8938cb89ab00f0424f5a685b74d3ed78f45f5 /package/iproute2/Makefile
parent83948d6385c9ce23545a159ffd64f5b2854332ed (diff)
downloadmaster-31e0f0ae-f638b544f3b2ffe568f581f0225760ef6cc31d92.tar.gz
master-31e0f0ae-f638b544f3b2ffe568f581f0225760ef6cc31d92.tar.bz2
master-31e0f0ae-f638b544f3b2ffe568f581f0225760ef6cc31d92.zip
iproute2: Add hotplug script to add slave devices to TEQL master
Resolves https://dev.openwrt.org/ticket/11192 Signed-off-by: David Woodhouse <dwmw2@infradead.org> SVN-Revision: 31311
Diffstat (limited to 'package/iproute2/Makefile')
-rw-r--r--package/iproute2/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/package/iproute2/Makefile b/package/iproute2/Makefile
index 3b442583ed..0a2f411533 100644
--- a/package/iproute2/Makefile
+++ b/package/iproute2/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=iproute2
PKG_VERSION:=3.2.0
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://kernel.org/pub/linux/utils/net/iproute2/
@@ -96,6 +96,8 @@ endef
define Package/tc/install
$(INSTALL_DIR) $(1)/usr/sbin
$(INSTALL_BIN) $(PKG_BUILD_DIR)/tc/tc $(1)/usr/sbin/
+ $(INSTALL_DIR) $(1)/etc/hotplug.d/iface
+ $(INSTALL_BIN) ./files/30-teql $(1)/etc/hotplug.d/iface/
endef
define Package/genl/install