summaryrefslogtreecommitdiffstats
path: root/package/hostapd
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-11-16 23:37:24 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-11-16 23:37:24 +0000
commit992e1f5e0476b90b6371de3413f493ee03ecdb29 (patch)
tree6fb66e335591c24763018513aee39c9bb0962d82 /package/hostapd
parent63c05b7e2e25c700828b61fd4e74b4163ec0fa88 (diff)
downloadmaster-31e0f0ae-992e1f5e0476b90b6371de3413f493ee03ecdb29.tar.gz
master-31e0f0ae-992e1f5e0476b90b6371de3413f493ee03ecdb29.tar.bz2
master-31e0f0ae-992e1f5e0476b90b6371de3413f493ee03ecdb29.zip
fix hostapd build with openssl
SVN-Revision: 9574
Diffstat (limited to 'package/hostapd')
-rw-r--r--package/hostapd/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/package/hostapd/Makefile b/package/hostapd/Makefile
index 8cdbd7750a..af215f6fff 100644
--- a/package/hostapd/Makefile
+++ b/package/hostapd/Makefile
@@ -17,7 +17,7 @@ PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=git://w1.fi/srv/git/hostap.git
PKG_SOURCE_SUBDIR:=hostapd-$(PKG_VERSION)
PKG_SOURCE_VERSION:=$(PKG_REV)
-PKG_BUILD_DEPENDS:=madwifi mac80211 libnl
+PKG_BUILD_DEPENDS:=madwifi mac80211 libnl openssl
include $(INCLUDE_DIR)/package.mk
$(eval $(call confvar,STAMP_CONFIGURED,CONFIG_PACKAGE_kmod-mac80211 CONFIG_PACKAGE_kmod-madwifi))
@@ -83,7 +83,8 @@ define Build/CompileTarget
$(MAKE) -C $(PKG_BUILD_DIR)/hostapd.$(1) \
$(TARGET_CONFIGURE_OPTS) \
LIBS="$(TARGET_LDFLAGS) -L$(STAGING_DIR)/usr/lib \
- $(if $(CONFIG_PACKAGE_kmod-mac80211),-lm $(STAGING_DIR)/usr/lib/libnl.a)" \
+ $(if $(CONFIG_PACKAGE_kmod-mac80211),-lm $(STAGING_DIR)/usr/lib/libnl.a) \
+ $(if $(findstring default,$(1)),-lssl -lcrypto)" \
hostapd hostapd_cli
$(CP) $(PKG_BUILD_DIR)/hostapd.$(1)/hostapd_cli $(PKG_BUILD_DIR)/
endef