summaryrefslogtreecommitdiffstats
path: root/package/hostapd/patches/007-add-nl80211-driver.patch
diff options
context:
space:
mode:
authorMichael Büsch <mb@bu3sch.de>2008-02-17 12:18:33 +0000
committerMichael Büsch <mb@bu3sch.de>2008-02-17 12:18:33 +0000
commit306caa660a09295dbe1cc2f4c184a89b38591661 (patch)
treed9038a109067ad5edb3fc9e1089737aedae15e55 /package/hostapd/patches/007-add-nl80211-driver.patch
parentf116c50a801acc77a1d1d56809970a2a4c0a0ded (diff)
downloadmaster-31e0f0ae-306caa660a09295dbe1cc2f4c184a89b38591661.tar.gz
master-31e0f0ae-306caa660a09295dbe1cc2f4c184a89b38591661.tar.bz2
master-31e0f0ae-306caa660a09295dbe1cc2f4c184a89b38591661.zip
hostapd: use patches to add the nl80211 driver instead of copying the files.
SVN-Revision: 10475
Diffstat (limited to 'package/hostapd/patches/007-add-nl80211-driver.patch')
-rw-r--r--package/hostapd/patches/007-add-nl80211-driver.patch41
1 files changed, 0 insertions, 41 deletions
diff --git a/package/hostapd/patches/007-add-nl80211-driver.patch b/package/hostapd/patches/007-add-nl80211-driver.patch
deleted file mode 100644
index 6c450fcda2..0000000000
--- a/package/hostapd/patches/007-add-nl80211-driver.patch
+++ /dev/null
@@ -1,41 +0,0 @@
-Index: hostapd-20071107_03ec0ec5cdb974d51a4a2a566bea4c4568138576/hostapd/Makefile
-===================================================================
---- hostapd-20071107_03ec0ec5cdb974d51a4a2a566bea4c4568138576.orig/hostapd/Makefile 2008-02-16 19:44:22.000000000 +0100
-+++ hostapd-20071107_03ec0ec5cdb974d51a4a2a566bea4c4568138576/hostapd/Makefile 2008-02-16 19:44:34.000000000 +0100
-@@ -121,6 +121,12 @@ OBJS += driver_devicescape.o
- LIBS += -lnl
- endif
-
-+ifdef CONFIG_DRIVER_NL80211
-+CFLAGS += -DCONFIG_DRIVER_NL80211
-+OBJS += driver_nl80211.o radiotap.o
-+LIBS += -lnl
-+endif
-+
- ifdef CONFIG_DRIVER_BSD
- CFLAGS += -DCONFIG_DRIVER_BSD
- OBJS += driver_bsd.o
-Index: hostapd-20071107_03ec0ec5cdb974d51a4a2a566bea4c4568138576/hostapd/drivers.c
-===================================================================
---- hostapd-20071107_03ec0ec5cdb974d51a4a2a566bea4c4568138576.orig/hostapd/drivers.c 2007-11-16 05:08:24.000000000 +0100
-+++ hostapd-20071107_03ec0ec5cdb974d51a4a2a566bea4c4568138576/hostapd/drivers.c 2008-02-16 19:56:29.000000000 +0100
-@@ -22,6 +22,9 @@ extern struct wpa_driver_ops wpa_driver_
- /* driver_devicescape.c */
- extern struct wpa_driver_ops wpa_driver_devicescape_ops;
- #endif /* CONFIG_DRIVER_DEVICESCAPE */
-+#ifdef CONFIG_DRIVER_NL80211
-+extern struct wpa_driver_ops wpa_driver_nl80211_ops; /* driver_nl80211.c */
-+#endif /* CONFIG_DRIVER_NL80211 */
- #ifdef CONFIG_DRIVER_PRISM54
- extern struct wpa_driver_ops wpa_driver_prism54_ops; /* driver_prism54.c */
- #endif /* CONFIG_DRIVER_PRISM54 */
-@@ -47,6 +50,9 @@ struct wpa_driver_ops *hostapd_drivers[]
- #ifdef CONFIG_DRIVER_DEVICESCAPE
- &wpa_driver_devicescape_ops,
- #endif /* CONFIG_DRIVER_DEVICESCAPE */
-+#ifdef CONFIG_DRIVER_NL80211
-+ &wpa_driver_nl80211_ops,
-+#endif /* CONFIG_DRIVER_NL80211 */
- #ifdef CONFIG_DRIVER_PRISM54
- &wpa_driver_prism54_ops,
- #endif /* CONFIG_DRIVER_PRISM54 */