summaryrefslogtreecommitdiffstats
path: root/package/hostapd/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2008-10-01 21:26:19 +0000
committerFelix Fietkau <nbd@openwrt.org>2008-10-01 21:26:19 +0000
commitb0e7c7ba79625e2331c4898cc1c2b5f39ea7a651 (patch)
tree066b8b687fb17d0931f080a143343324fbcc27c2 /package/hostapd/Makefile
parentfe1570e63bf96043fbfb93e3698ee60ba92a913d (diff)
downloadmaster-31e0f0ae-b0e7c7ba79625e2331c4898cc1c2b5f39ea7a651.tar.gz
master-31e0f0ae-b0e7c7ba79625e2331c4898cc1c2b5f39ea7a651.tar.bz2
master-31e0f0ae-b0e7c7ba79625e2331c4898cc1c2b5f39ea7a651.zip
implement conditional dependencies for menuconfig and build deps
SVN-Revision: 12820
Diffstat (limited to 'package/hostapd/Makefile')
-rw-r--r--package/hostapd/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/package/hostapd/Makefile b/package/hostapd/Makefile
index e9d8a5c2cc..8f8af96b1e 100644
--- a/package/hostapd/Makefile
+++ b/package/hostapd/Makefile
@@ -17,7 +17,7 @@ PKG_SOURCE_URL:=http://hostap.epitest.fi/releases/
PKG_SOURCE_SUBDIR:=hostapd-$(PKG_VERSION)
PKG_SOURCE_VERSION:=$(PKG_REV)
PKG_MD5SUM:=62876f2179f316db0621cc33adf04c19
-PKG_BUILD_DEPENDS:=madwifi mac80211 libnl openssl
+PKG_BUILD_DEPENDS:=PACKAGE_kmod-madwifi:madwifi PACKAGE_kmod-mac80211:mac80211 PACKAGE_kmod-mac80211:libnl
include $(INCLUDE_DIR)/package.mk
STAMP_CONFIGURED:=$(STAMP_CONFIGURED)_$(call confvar,CONFIG_PACKAGE_kmod-mac80211 CONFIG_PACKAGE_kmod-madwifi CONFIG_PACKAGE_hostapd CONFIG_PACKAGE_hostapd-mini)
@@ -33,7 +33,7 @@ endef
define Package/hostapd
$(call Package/hostapd/Default)
TITLE+= (full)
- DEPENDS+= +libopenssl
+ DEPENDS+= +PACKAGE_hostapd:libopenssl
endef
#define Package/hostapd/conffiles