summaryrefslogtreecommitdiffstats
path: root/package/hostapd/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2009-10-20 21:14:57 +0000
committerFelix Fietkau <nbd@openwrt.org>2009-10-20 21:14:57 +0000
commita7cba046e643ae9340ae1c32cf58683b161be0d4 (patch)
tree87ce582b738e9aae23eadc9e4fef96c9ed5517ef /package/hostapd/Makefile
parent73723393f94d1f264f92b6f787f3698e6fce69d2 (diff)
downloadmaster-31e0f0ae-a7cba046e643ae9340ae1c32cf58683b161be0d4.tar.gz
master-31e0f0ae-a7cba046e643ae9340ae1c32cf58683b161be0d4.tar.bz2
master-31e0f0ae-a7cba046e643ae9340ae1c32cf58683b161be0d4.zip
hostapd: make compilation of the hostap driver conditional - saves 10k uncompressed
SVN-Revision: 18107
Diffstat (limited to 'package/hostapd/Makefile')
-rw-r--r--package/hostapd/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/package/hostapd/Makefile b/package/hostapd/Makefile
index 55bef9bfdd..ddf21683bd 100644
--- a/package/hostapd/Makefile
+++ b/package/hostapd/Makefile
@@ -27,12 +27,14 @@ PKG_CONFIG_DEPENDS:= \
CONFIG_PACKAGE_kmod-madwifi \
CONFIG_PACKAGE_hostapd \
CONFIG_PACKAGE_hostapd-mini \
+ CONFIG_PACKAGE_kmod-hostap
include $(INCLUDE_DIR)/package.mk
DRIVER_MAKEOPTS= \
CONFIG_DRIVER_NL80211=$(CONFIG_PACKAGE_kmod-mac80211) \
CONFIG_DRIVER_MADWIFI=$(CONFIG_PACKAGE_kmod-madwifi) \
+ CONFIG_DRIVER_HOSTAP=$(CONFIG_PACKAGE_kmod-hostap) \
CONFIG_IEEE80211N=$(CONFIG_PACKAGE_kmod-ath9k)
define Package/hostapd/Default