summaryrefslogtreecommitdiffstats
path: root/package/hostap
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-04-18 12:28:38 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-04-18 12:28:38 +0000
commit4c6c987f09c6973bb49aa452aca8332f6e620d12 (patch)
treec9a979ef4473f55e9a33a1c8d58eef183b673993 /package/hostap
parenta3a9e039d87cbcd2efc47004e8bce099570a9020 (diff)
downloadmaster-31e0f0ae-4c6c987f09c6973bb49aa452aca8332f6e620d12.tar.gz
master-31e0f0ae-4c6c987f09c6973bb49aa452aca8332f6e620d12.tar.bz2
master-31e0f0ae-4c6c987f09c6973bb49aa452aca8332f6e620d12.zip
Improved autorebuild for kernel related stuff. - make modules_install in the kernel tree is no longer called - make modules is called on every target/compile run - kmod packages pull the kernel modules directly out of the kernel tree and have proper file depends on them
SVN-Revision: 6998
Diffstat (limited to 'package/hostap')
-rw-r--r--package/hostap/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/package/hostap/Makefile b/package/hostap/Makefile
index d3d5fb6518..b4d24460c3 100644
--- a/package/hostap/Makefile
+++ b/package/hostap/Makefile
@@ -61,7 +61,7 @@ endef
define KernelPackage/hostap/2.6
KCONFIG:=$(CONFIG_HOSTAP)
FILES:= \
- $(MODULES_DIR)/kernel/drivers/net/wireless/hostap/hostap.$(LINUX_KMOD_SUFFIX)
+ $(LINUX_DIR)/drivers/net/wireless/hostap/hostap.$(LINUX_KMOD_SUFFIX)
AUTOLOAD:=$(call AutoLoad,60,hostap)
endef
@@ -82,7 +82,7 @@ endef
define KernelPackage/hostap-pci/2.6
KCONFIG:=$(CONFIG_HOSTAP_PCI)
FILES:= \
- $(MODULES_DIR)/kernel/drivers/net/wireless/hostap/hostap_pci.$(LINUX_KMOD_SUFFIX)
+ $(LINUX_DIR)/drivers/net/wireless/hostap/hostap_pci.$(LINUX_KMOD_SUFFIX)
endef
@@ -103,7 +103,7 @@ endef
define KernelPackage/hostap-plx/2.6
KCONFIG:=$(CONFIG_HOSTAP_PLX)
FILES:= \
- $(MODULES_DIR)/kernel/drivers/net/wireless/hostap/hostap_plx.$(LINUX_KMOD_SUFFIX)
+ $(LINUX_DIR)/drivers/net/wireless/hostap/hostap_plx.$(LINUX_KMOD_SUFFIX)
endef