summaryrefslogtreecommitdiffstats
path: root/package/foxboard-utils
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2007-06-02 22:58:00 +0000
committerJohn Crispin <john@openwrt.org>2007-06-02 22:58:00 +0000
commita1e0545d4b44f8502dd4c3ee6537db2473344824 (patch)
tree7d8f88d8f3404907caf77fde368bf5950036689b /package/foxboard-utils
parent908b616d8e9f35658b71fdb525afff4e43cf703c (diff)
downloadmaster-31e0f0ae-a1e0545d4b44f8502dd4c3ee6537db2473344824.tar.gz
master-31e0f0ae-a1e0545d4b44f8502dd4c3ee6537db2473344824.tar.bz2
master-31e0f0ae-a1e0545d4b44f8502dd4c3ee6537db2473344824.zip
added some tools that the foxboard users are used to, when working with the fox
SVN-Revision: 7463
Diffstat (limited to 'package/foxboard-utils')
-rw-r--r--package/foxboard-utils/Makefile45
1 files changed, 45 insertions, 0 deletions
diff --git a/package/foxboard-utils/Makefile b/package/foxboard-utils/Makefile
new file mode 100644
index 0000000000..c2ff1d1133
--- /dev/null
+++ b/package/foxboard-utils/Makefile
@@ -0,0 +1,45 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+# $Id: Makefile 7006 2007-04-19 12:06:39Z kaloz $
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=foxboard-utils
+PKG_VERSION:=1
+PKG_RELEASE:=1
+
+PKG_SOURCE:=foxboard-utils.tar.bz2
+PKG_SOURCE_URL:=http://www.acmesystems.it/download/owrt
+PKG_MD5SUM:=
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/foxboard-utils
+ SECTION:=utils
+ CATEGORY:=Base system
+ TITLE:=Foxboard base tools
+ DESCRIPTION:=\
+ This package contains a collection of tools for configuring the foxboard gpio pins/leds
+ URL:=http://www.acmesystems.it
+ DEPENDS:=@LINUX_2_6_ETRAX
+endef
+
+define Build/Compile
+ $(MAKE) -C $(PKG_BUILD_DIR) CFLAGS=$(TARTGET_CFLAGS) CC=$(TARGET_CC)
+ $(MAKE) -C $(PKG_BUILD_DIR) PREFIX="$(PKG_INSTALL_DIR)" install
+endef
+
+define Package/foxboard-utils/install
+ $(INSTALL_DIR) $(1)/
+ $(CP) $(PKG_INSTALL_DIR)/* $(1)
+ mkdir $(1)/www/cgi
+ cd $(1)/www/cgi; ln -s ../../bin/edit.cgi .
+endef
+
+$(eval $(call BuildPackage,foxboard-utils))