summaryrefslogtreecommitdiffstats
path: root/package/firmware
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke.mehrtens@intel.com>2016-06-24 15:46:31 +0200
committerHauke Mehrtens <hauke@hauke-m.de>2016-06-30 19:42:59 +0200
commitffcae8b494df37f887ad96eaaccdb93c1a401787 (patch)
treef28fbc802646e09c847479e21ad6dd39060d6cb0 /package/firmware
parent37fa64a6c54634df8d81066277e614d68efeaca7 (diff)
downloadmaster-31e0f0ae-ffcae8b494df37f887ad96eaaccdb93c1a401787.tar.gz
master-31e0f0ae-ffcae8b494df37f887ad96eaaccdb93c1a401787.tar.bz2
master-31e0f0ae-ffcae8b494df37f887ad96eaaccdb93c1a401787.zip
prism54-firmware: add also other p54 firmware to own package
Extract the other p54 firmware files into the prism54-firmware package. Signed-off-by: Hauke Mehrtens <hauke.mehrtens@intel.com>
Diffstat (limited to 'package/firmware')
-rw-r--r--package/firmware/prism54-firmware/Makefile73
1 files changed, 71 insertions, 2 deletions
diff --git a/package/firmware/prism54-firmware/Makefile b/package/firmware/prism54-firmware/Makefile
index 759e6b0abe..32bd289520 100644
--- a/package/firmware/prism54-firmware/Makefile
+++ b/package/firmware/prism54-firmware/Makefile
@@ -9,20 +9,70 @@ PKG_NAME:=prism54-firmware
PKG_VERSION:=1.0.4.3
PKG_RELEASE:=1
+PRG_URL:=https://daemonizer.de/prism54/prism54-fw/
+
# Prism54 FullMAC firmware (jbnore.free.fr seems to be rather slow, so we use daemonizer.de)
PKG_SOURCE:=$(PKG_VERSION).arm
-PKG_SOURCE_URL:=https://daemonizer.de/prism54/prism54-fw/fw-fullmac/
+PKG_SOURCE_URL:=$(PRG_URL)/fw-fullmac/
PKG_MD5SUM:=8bd4310971772a486b9784c77f8a6df9
include $(INCLUDE_DIR)/package.mk
-define Package/prism54-firmware
+
+# Prism54 drivers
+P54USBFW:=2.13.24.0.lm87.arm
+P54PCIFW:=2.13.12.0.arm
+P54SPIFW:=2.13.0.0.a.13.14.arm
+
+define Download/p54-usb-firmware
+ FILE:=$(P54USBFW)
+ URL:=$(PRG_URL)/fw-usb
+ MD5SUM:=8e8ab005a4f8f0123bcdc51bc25b47f6
+endef
+$(eval $(call Download,p54-usb-firmware))
+
+define Download/p54-pci-firmware
+ FILE:=$(P54PCIFW)
+ URL:=$(PRG_URL)/fw-softmac
+ MD5SUM:=ff7536af2092b1c4b21315bd103ef4c4
+endef
+$(eval $(call Download,p54-pci-firmware))
+
+define Download/p54-spi-firmware
+ FILE:=$(P54SPIFW)
+ URL:=$(PRG_URL)/stlc4560
+ MD5SUM:=42661f8ecbadd88012807493f596081d
+endef
+$(eval $(call Download,p54-spi-firmware))
+
+
+define Package/prism54-firmware-default
SECTION:=firmware
CATEGORY:=Firmware
URL:=https://daemonizer.de/prism54/prism54-fw
+endef
+
+define Package/prism54-firmware
+$(Package/prism54-firmware-default)
TITLE:=prism54 firmware
endef
+define Package/p54-usb-firmware
+$(Package/prism54-firmware-default)
+ TITLE:=p54-usb firmware
+endef
+
+define Package/p54-pci-firmware
+$(Package/prism54-firmware-default)
+ TITLE:=p54-pci firmware
+endef
+
+define Package/p54-spi-firmware
+$(Package/prism54-firmware-default)
+ TITLE:=p54-spi firmware
+endef
+
+
define Build/Prepare
mkdir -p $(PKG_BUILD_DIR)
endef
@@ -36,4 +86,23 @@ define Package/prism54-firmware/install
$(INSTALL_DATA) $(DL_DIR)/$(PKG_SOURCE) $(1)/lib/firmware/isl3890
endef
+define Package/p54-usb-firmware/install
+ $(INSTALL_DIR) $(1)/lib/firmware
+ $(INSTALL_DATA) $(DL_DIR)/$(P54USBFW) $(1)/lib/firmware/isl3887usb
+endef
+
+define Package/p54-pci-firmware/install
+ $(INSTALL_DIR) $(1)/lib/firmware
+ $(INSTALL_DATA) $(DL_DIR)/$(P54PCIFW) $(1)/lib/firmware/isl3886pci
+endef
+
+define Package/p54-spi-firmware/install
+ $(INSTALL_DIR) $(1)/lib/firmware
+ $(INSTALL_DATA) $(DL_DIR)/$(P54SPIFW) $(1)/lib/firmware/3826.arm
+endef
+
+
$(eval $(call BuildPackage,prism54-firmware))
+$(eval $(call BuildPackage,p54-usb-firmware))
+$(eval $(call BuildPackage,p54-pci-firmware))
+$(eval $(call BuildPackage,p54-spi-firmware))