summaryrefslogtreecommitdiffstats
path: root/package/firmware
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2016-02-22 08:54:08 +0000
committerFelix Fietkau <nbd@openwrt.org>2016-02-22 08:54:08 +0000
commitcd33dd3f7c5419c99a6fc06f05e51650ad75b41a (patch)
tree5c0bdf68a6b98530351664fac367e3a822ddf1b4 /package/firmware
parentfc47eb07941c6d32cb6e974fccf73ee19a4d1d9c (diff)
downloadmaster-31e0f0ae-cd33dd3f7c5419c99a6fc06f05e51650ad75b41a.tar.gz
master-31e0f0ae-cd33dd3f7c5419c99a6fc06f05e51650ad75b41a.tar.bz2
master-31e0f0ae-cd33dd3f7c5419c99a6fc06f05e51650ad75b41a.zip
mac80211: add packages libertas-spi module and firmware
This adds option to build kernel module and firmware packages for a Marvell 8686 SPI Wireless device Signed-off-by: Joseph Honold <mozzwald@gmail.com> SVN-Revision: 48750
Diffstat (limited to 'package/firmware')
-rw-r--r--package/firmware/linux-firmware/marvell.mk10
1 files changed, 10 insertions, 0 deletions
diff --git a/package/firmware/linux-firmware/marvell.mk b/package/firmware/linux-firmware/marvell.mk
index 86c0e6fede..752a8e0b4e 100644
--- a/package/firmware/linux-firmware/marvell.mk
+++ b/package/firmware/linux-firmware/marvell.mk
@@ -44,3 +44,13 @@ define Package/libertas-sdio-firmware/install
endef
$(eval $(call BuildPackage,libertas-sdio-firmware))
+Package/libertas-spi-firmware = $(call Package/firmware-default,Marvell 8686 SPI firmware)
+define Package/libertas-spi-firmware/install
+ $(INSTALL_DIR) $(1)/lib/firmware/libertas
+ $(INSTALL_DATA) \
+ $(PKG_BUILD_DIR)/libertas/gspi8686_v9_helper.bin \
+ $(PKG_BUILD_DIR)/libertas/gspi8686_v9.bin \
+ $(1)/lib/firmware/libertas
+endef
+$(eval $(call BuildPackage,libertas-spi-firmware))
+