summaryrefslogtreecommitdiffstats
path: root/package/firmware
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke.mehrtens@intel.com>2016-06-22 17:46:21 +0200
committerHauke Mehrtens <hauke@hauke-m.de>2016-06-30 19:21:02 +0200
commit37fa64a6c54634df8d81066277e614d68efeaca7 (patch)
tree19cb3bf1e106329b9e7f813bb4d0772bd9045d9c /package/firmware
parent0a0caa2656c8db73518a1783743ede772e3ac40f (diff)
downloadmaster-31e0f0ae-37fa64a6c54634df8d81066277e614d68efeaca7.tar.gz
master-31e0f0ae-37fa64a6c54634df8d81066277e614d68efeaca7.tar.bz2
master-31e0f0ae-37fa64a6c54634df8d81066277e614d68efeaca7.zip
firmware: extract prism54-firmware into own package
Instead of downloading the firmware for prism54 devices in the wireless.mk do it in an extra package Makefile. To ship the complete source code Intel ships our modified OpenWrt/LEDE + the content of the dl directory. We do not want to have any files in the dl/ directory which are not needed to build our images. The prism54 gets downloaded every time independently of building kmod-net-prism54 or not. When it is in a own package it only gets downloaded when the firmware package is selected. Signed-off-by: Hauke Mehrtens <hauke.mehrtens@intel.com>
Diffstat (limited to 'package/firmware')
-rw-r--r--package/firmware/prism54-firmware/Makefile39
1 files changed, 39 insertions, 0 deletions
diff --git a/package/firmware/prism54-firmware/Makefile b/package/firmware/prism54-firmware/Makefile
new file mode 100644
index 0000000000..759e6b0abe
--- /dev/null
+++ b/package/firmware/prism54-firmware/Makefile
@@ -0,0 +1,39 @@
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=prism54-firmware
+PKG_VERSION:=1.0.4.3
+PKG_RELEASE:=1
+
+# Prism54 FullMAC firmware (jbnore.free.fr seems to be rather slow, so we use daemonizer.de)
+PKG_SOURCE:=$(PKG_VERSION).arm
+PKG_SOURCE_URL:=https://daemonizer.de/prism54/prism54-fw/fw-fullmac/
+PKG_MD5SUM:=8bd4310971772a486b9784c77f8a6df9
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/prism54-firmware
+ SECTION:=firmware
+ CATEGORY:=Firmware
+ URL:=https://daemonizer.de/prism54/prism54-fw
+ TITLE:=prism54 firmware
+endef
+
+define Build/Prepare
+ mkdir -p $(PKG_BUILD_DIR)
+endef
+
+define Build/Compile
+
+endef
+
+define Package/prism54-firmware/install
+ $(INSTALL_DIR) $(1)/lib/firmware
+ $(INSTALL_DATA) $(DL_DIR)/$(PKG_SOURCE) $(1)/lib/firmware/isl3890
+endef
+
+$(eval $(call BuildPackage,prism54-firmware))