summaryrefslogtreecommitdiffstats
path: root/package/firmware
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2016-01-10 16:35:46 +0000
committerFelix Fietkau <nbd@openwrt.org>2016-01-10 16:35:46 +0000
commitb6fcd06204798afe2e11c094e3206dae7c4b7788 (patch)
tree6e59cc95a082c4dc179e70bad9564466d0ba045b /package/firmware
parent2d21f6c6d667ba34612b3fb4aa4f4e64fbb4231b (diff)
downloadmaster-31e0f0ae-b6fcd06204798afe2e11c094e3206dae7c4b7788.tar.gz
master-31e0f0ae-b6fcd06204798afe2e11c094e3206dae7c4b7788.tar.bz2
master-31e0f0ae-b6fcd06204798afe2e11c094e3206dae7c4b7788.zip
linux-firmware: remove duplication in package metadata
Signed-off-by: Felix Fietkau <nbd@openwrt.org> SVN-Revision: 48174
Diffstat (limited to 'package/firmware')
-rw-r--r--package/firmware/linux-firmware/Makefile26
-rw-r--r--package/firmware/linux-firmware/realtek.mk19
2 files changed, 12 insertions, 33 deletions
diff --git a/package/firmware/linux-firmware/Makefile b/package/firmware/linux-firmware/Makefile
index 8b02bee2a0..e8b1b4d4d5 100644
--- a/package/firmware/linux-firmware/Makefile
+++ b/package/firmware/linux-firmware/Makefile
@@ -23,39 +23,33 @@ PKG_MAINTAINER:=Felix Fietkau <nbd@openwrt.org>
include $(INCLUDE_DIR)/package.mk
-define Package/ibt-firmware
+define Package/firmware-default
SECTION:=firmware
CATEGORY:=Firmware
URL:=http://git.kernel.org/cgit/linux/kernel/git/firmware/linux-firmware.git
- TITLE:=Intel bluetooth firmware
+ TITLE:=$(1)
endef
+define Build/Compile
+
+endef
+
+Package/ibt-firmware = $(call Package/firmware-default,Intel bluetooth firmware)
define Package/ibt-firmware/install
$(INSTALL_DIR) $(1)/lib/firmware/intel
$(CP) \
$(PKG_BUILD_DIR)/intel/*.bseq \
$(1)/lib/firmware/intel
endef
+$(eval $(call BuildPackage,ibt-firmware))
-define Package/ar3k-firmware
- SECTION:=firmware
- CATEGORY:=Firmware
- URL:=http://git.kernel.org/cgit/linux/kernel/git/firmware/linux-firmware.git
- TITLE:=ath3k firmware
-endef
-
+Package/ar3k-firmware = $(call Package/firmware-default,ath3k firmware)
define Package/ar3k-firmware/install
$(INSTALL_DIR) $(1)/lib/firmware/ar3k
$(CP) \
$(PKG_BUILD_DIR)/ar3k/*.dfu \
$(1)/lib/firmware/ar3k
endef
-
-define Build/Compile
-
-endef
+$(eval $(call BuildPackage,ar3k-firmware))
include $(wildcard ./*.mk)
-
-$(eval $(call BuildPackage,ar3k-firmware))
-$(eval $(call BuildPackage,ibt-firmware))
diff --git a/package/firmware/linux-firmware/realtek.mk b/package/firmware/linux-firmware/realtek.mk
index 9bf1cef3bf..5e3c34e6eb 100644
--- a/package/firmware/linux-firmware/realtek.mk
+++ b/package/firmware/linux-firmware/realtek.mk
@@ -1,32 +1,17 @@
-define Package/r8169-firmware
- SECTION:=firmware
- CATEGORY:=Firmware
- URL:=http://git.kernel.org/cgit/linux/kernel/git/firmware/linux-firmware.git
- TITLE:=RealTek r8169 firmware
-endef
-
+Package/r8169-firmware = $(call Package/firmware-default,RealTek RTL8169 firmware)
define Package/r8169-firmware/install
$(INSTALL_DIR) $(1)/lib/firmware/rtl_nic
$(CP) \
$(PKG_BUILD_DIR)/rtl_nic/* \
$(1)/lib/firmware/rtl_nic
endef
-
$(eval $(call BuildPackage,r8169-firmware))
-
-define Package/r8188eu-firmware
- SECTION:=firmware
- CATEGORY:=Firmware
- URL:=http://git.kernel.org/cgit/linux/kernel/git/firmware/linux-firmware.git
- TITLE:=RealTek r8188eu firmware
-endef
-
+Package/r8188eu-firmware = $(call Package/firmware-default,RealTek RTL8188EU firmware)
define Package/r8188eu-firmware/install
$(INSTALL_DIR) $(1)/lib/firmware/rtlwifi
$(CP) \
$(PKG_BUILD_DIR)/rtlwifi/rtl8188eufw.bin \
$(1)/lib/firmware/rtlwifi
endef
-
$(eval $(call BuildPackage,r8188eu-firmware))