summaryrefslogtreecommitdiffstats
path: root/package/firmware/linux-firmware
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2015-10-19 10:10:14 +0000
committerJohn Crispin <john@openwrt.org>2015-10-19 10:10:14 +0000
commitc3d310356d74f0f1991583ae08836dd0e23a907f (patch)
tree513a5eb3d7cb13d191585e6bbe7484515ad8f707 /package/firmware/linux-firmware
parent257e76a3df0ddff4583789755e78835d79ed2005 (diff)
downloadmaster-31e0f0ae-c3d310356d74f0f1991583ae08836dd0e23a907f.tar.gz
master-31e0f0ae-c3d310356d74f0f1991583ae08836dd0e23a907f.tar.bz2
master-31e0f0ae-c3d310356d74f0f1991583ae08836dd0e23a907f.zip
firmware: linux-firmware: Add ibt-firmware and ar3k-firmware packages
Some bluetooth devices require firmware. Add intel bluetooth and ar3k for now. Signed-off-by: Pushpal Sidhu <psidhu@gateworks.com> SVN-Revision: 47222
Diffstat (limited to 'package/firmware/linux-firmware')
-rw-r--r--package/firmware/linux-firmware/Makefile40
1 files changed, 40 insertions, 0 deletions
diff --git a/package/firmware/linux-firmware/Makefile b/package/firmware/linux-firmware/Makefile
index 015aff7554..fe682aba3d 100644
--- a/package/firmware/linux-firmware/Makefile
+++ b/package/firmware/linux-firmware/Makefile
@@ -61,3 +61,43 @@ define Package/r8188eu-firmware/install
endef
$(eval $(call BuildPackage,r8188eu-firmware))
+
+define Package/ibt-firmware
+ SECTION:=firmware
+ CATEGORY:=Firmware
+ URL:=http://git.kernel.org/cgit/linux/kernel/git/firmware/linux-firmware.git
+ TITLE:=Intel bluetooth firmware
+endef
+
+define Build/Compile
+
+endef
+
+define Package/ibt-firmware/install
+ $(INSTALL_DIR) $(1)/lib/firmware/intel
+ $(CP) \
+ $(PKG_BUILD_DIR)/intel/*.bseq \
+ $(1)/lib/firmware/intel
+endef
+
+$(eval $(call BuildPackage,ibt-firmware))
+
+define Package/ar3k-firmware
+ SECTION:=firmware
+ CATEGORY:=Firmware
+ URL:=http://git.kernel.org/cgit/linux/kernel/git/firmware/linux-firmware.git
+ TITLE:=ath3k firmware
+endef
+
+define Build/Compile
+
+endef
+
+define Package/ar3k-firmware/install
+ $(INSTALL_DIR) $(1)/lib/firmware/ar3k
+ $(CP) \
+ $(PKG_BUILD_DIR)/ar3k/*.dfu \
+ $(1)/lib/firmware/ar3k
+endef
+
+$(eval $(call BuildPackage,ar3k-firmware))