summaryrefslogtreecommitdiffstats
path: root/package/firmware/linux-firmware/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2014-04-10 14:43:30 +0000
committerFelix Fietkau <nbd@openwrt.org>2014-04-10 14:43:30 +0000
commitd589d40294c849f93f3768d0c27804e55674b6ed (patch)
tree376e7f067e74bd3cb4842b17f41f21433e1ca3e9 /package/firmware/linux-firmware/Makefile
parentd1969d761fc2c0d88b2970c9447d36bc67e108a6 (diff)
downloadmaster-31e0f0ae-d589d40294c849f93f3768d0c27804e55674b6ed.tar.gz
master-31e0f0ae-d589d40294c849f93f3768d0c27804e55674b6ed.tar.bz2
master-31e0f0ae-d589d40294c849f93f3768d0c27804e55674b6ed.zip
linux-firmware: add a new package for firmware (currently only builds r8169 firmware)
Signed-off-by: Felix Fietkau <nbd@openwrt.org> SVN-Revision: 40447
Diffstat (limited to 'package/firmware/linux-firmware/Makefile')
-rw-r--r--package/firmware/linux-firmware/Makefile43
1 files changed, 43 insertions, 0 deletions
diff --git a/package/firmware/linux-firmware/Makefile b/package/firmware/linux-firmware/Makefile
new file mode 100644
index 0000000000..fdc7de100e
--- /dev/null
+++ b/package/firmware/linux-firmware/Makefile
@@ -0,0 +1,43 @@
+#
+# Copyright (C) 2014 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=linux-firmware
+PKG_SOURCE_VERSION:=f8c22c692bdee57a20b092e647464ff6176df3ed
+PKG_VERSION:=2014-03-16-$(PKG_SOURCE_VERSION)
+PKG_RELEASE:=1
+
+PKG_SOURCE_PROTO:=git
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
+PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
+PKG_SOURCE_URL:=git://git.kernel.org/pub/scm/linux/kernel/git/firmware/linux-firmware.git
+PKG_MIRROR_MD5SUM:=ca4d289ad9380471cae376fc7dd3660a
+
+PKG_MAINTAINER:=Felix Fietkau <nbd@openwrt.org>
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/r8169-firmware
+ SECTION:=firmware
+ CATEGORY:=Firmware
+ URL:=http://git.kernel.org/cgit/linux/kernel/git/firmware/linux-firmware.git
+ TITLE:=RealTek r8169 firmware
+endef
+
+define Build/Compile
+
+endef
+
+define Package/r8169-firmware/install
+ $(INSTALL_DIR) $(1)/lib/firmware/rtl_nic
+ $(CP) \
+ $(PKG_BUILD_DIR)/rtl_nic/* \
+ $(1)/lib/firmware/rtl_nic
+endef
+
+$(eval $(call BuildPackage,r8169-firmware))