summaryrefslogtreecommitdiffstats
path: root/package/firmware/ath10k-firmware
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-10-30 22:01:22 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-10-30 22:01:22 +0000
commitd89b1ea7064b685502cea7a591c486bbc0c8e1fd (patch)
treef40631feb0c7cb97c8f5ebba8e187573513f01ac /package/firmware/ath10k-firmware
parent3fd8621f623b061ede340909ccba504b2828908d (diff)
downloadmaster-31e0f0ae-d89b1ea7064b685502cea7a591c486bbc0c8e1fd.tar.gz
master-31e0f0ae-d89b1ea7064b685502cea7a591c486bbc0c8e1fd.tar.bz2
master-31e0f0ae-d89b1ea7064b685502cea7a591c486bbc0c8e1fd.zip
ath10k-firmware: add qca99x0 firmware
Signed-off-by: Felix Fietkau <nbd@openwrt.org> SVN-Revision: 47295
Diffstat (limited to 'package/firmware/ath10k-firmware')
-rw-r--r--package/firmware/ath10k-firmware/Makefile20
1 files changed, 20 insertions, 0 deletions
diff --git a/package/firmware/ath10k-firmware/Makefile b/package/firmware/ath10k-firmware/Makefile
index bce0f80639..ac95543867 100644
--- a/package/firmware/ath10k-firmware/Makefile
+++ b/package/firmware/ath10k-firmware/Makefile
@@ -33,6 +33,15 @@ define Package/ath10k-firmware-qca988x
TITLE:=ath10k firmware for QCA988x devices
endef
+define Package/ath10k-firmware-qca99x0
+ SECTION:=kernel
+ CATEGORY:=Kernel modules
+ SUBMENU:=$(WMENU)
+ URL:=$(PKG_SOURCE_URL)
+ DEPENDS:=kmod-ath10k
+ TITLE:=ath10k firmware for QCA99x0 devices
+endef
+
define Build/Compile
endef
@@ -47,4 +56,15 @@ define Package/ath10k-firmware-qca988x/install
$(1)/lib/firmware/ath10k/QCA988X/hw2.0/firmware-5.bin
endef
+define Package/ath10k-firmware-qca99x0/install
+ $(INSTALL_DIR) $(1)/lib/firmware/ath10k/QCA99X0/hw2.0
+ $(INSTALL_DATA) \
+ $(PKG_BUILD_DIR)/QCA99X0/hw2.0/boardData_AR900B_CUS239_5G_v2_001.bin \
+ $(1)/lib/firmware/ath10k/QCA99X0/hw2.0/board.bin
+ $(INSTALL_DATA) \
+ $(PKG_BUILD_DIR)/QCA99X0/hw2.0/firmware-5.bin_10.4.1.00030-1 \
+ $(1)/lib/firmware/ath10k/QCA99X0/hw2.0/firmware-5.bin
+endef
+
$(eval $(call BuildPackage,ath10k-firmware-qca988x))
+$(eval $(call BuildPackage,ath10k-firmware-qca99x0))