summaryrefslogtreecommitdiffstats
path: root/package/firmware/ath10k-firmware/Makefile
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2015-12-23 14:45:22 +0000
committerJohn Crispin <john@openwrt.org>2015-12-23 14:45:22 +0000
commit5ba6a654e48bee356f6a8ec406624b71c206fff5 (patch)
treebf45f683e5df425002e02419f32b5fbca04784ad /package/firmware/ath10k-firmware/Makefile
parent698edbbc322a021c5a2231919cef4532187d3638 (diff)
downloadmaster-31e0f0ae-5ba6a654e48bee356f6a8ec406624b71c206fff5.tar.gz
master-31e0f0ae-5ba6a654e48bee356f6a8ec406624b71c206fff5.tar.bz2
master-31e0f0ae-5ba6a654e48bee356f6a8ec406624b71c206fff5.zip
ath10k-firmware: Update QCA988X firmware to 10.2.4.97-1
Signed-off-by: Martin Blumenstingl <martin.blumenstingl@googlemail.com> SVN-Revision: 47984
Diffstat (limited to 'package/firmware/ath10k-firmware/Makefile')
-rw-r--r--package/firmware/ath10k-firmware/Makefile13
1 files changed, 11 insertions, 2 deletions
diff --git a/package/firmware/ath10k-firmware/Makefile b/package/firmware/ath10k-firmware/Makefile
index 596cf1f808..882294cef3 100644
--- a/package/firmware/ath10k-firmware/Makefile
+++ b/package/firmware/ath10k-firmware/Makefile
@@ -8,7 +8,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=ath10k-firmware
-PKG_SOURCE_VERSION:=69f955c3dd95d97c7c30960aa5c9852c80b85cc3
+PKG_SOURCE_VERSION:=77f72b5f7dd940386d9e619a17904987759b7186
PKG_VERSION:=2014-11-13-$(PKG_SOURCE_VERSION)
PKG_RELEASE:=1
@@ -37,6 +37,15 @@ $(Package/ath10k-firmware-default)
TITLE:=ath10k firmware for QCA988x devices
endef
+QCA988X_FIRMWARE_FILE:=firmware-5.bin_10.2.4.97-1
+
+define Download/ath10k-firmware-qca988x
+ URL:=https://www.codeaurora.org/cgit/quic/qsdk/oss/firmware/ath10k-firmware/plain/10.2.4/
+ FILE:=$(QCA988X_FIRMWARE_FILE)
+ MD5SUM:=fcb2fbd42d73a63fbf603505c718cbde
+endef
+$(eval $(call Download,ath10k-firmware-qca988x))
+
define Package/ath10k-firmware-qca99x0
$(Package/ath10k-firmware-default)
TITLE:=ath10k firmware for QCA99x0 devices
@@ -68,7 +77,7 @@ define Package/ath10k-firmware-qca988x/install
$(PKG_BUILD_DIR)/QCA988X/board.bin \
$(1)/lib/firmware/ath10k/QCA988X/hw2.0/
$(INSTALL_DATA) \
- $(PKG_BUILD_DIR)/QCA988X/10.2.4/firmware-5.bin_10.2.4.70.12-2 \
+ $(DL_DIR)/$(QCA988X_FIRMWARE_FILE) \
$(1)/lib/firmware/ath10k/QCA988X/hw2.0/firmware-5.bin
endef