summaryrefslogtreecommitdiffstats
path: root/package/firewall
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2012-02-07 18:35:48 +0000
committerJo-Philipp Wich <jow@openwrt.org>2012-02-07 18:35:48 +0000
commit5609ad736e4cbaf3cc44bf47964690ac204a3f3a (patch)
tree861264fdf788eb4204f05d707dfc5d0f00c15b53 /package/firewall
parenta543eeb0aa5b775eced7ca5f85aaa20a2d243065 (diff)
downloadmaster-31e0f0ae-5609ad736e4cbaf3cc44bf47964690ac204a3f3a.tar.gz
master-31e0f0ae-5609ad736e4cbaf3cc44bf47964690ac204a3f3a.tar.bz2
master-31e0f0ae-5609ad736e4cbaf3cc44bf47964690ac204a3f3a.zip
firewall: don't filter IPv4 ICMP types (#10928)
SVN-Revision: 30363
Diffstat (limited to 'package/firewall')
-rw-r--r--package/firewall/Makefile2
-rw-r--r--package/firewall/files/lib/fw.sh5
2 files changed, 2 insertions, 5 deletions
diff --git a/package/firewall/Makefile b/package/firewall/Makefile
index 746cca4882..978154b3f7 100644
--- a/package/firewall/Makefile
+++ b/package/firewall/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=firewall
PKG_VERSION:=2
-PKG_RELEASE:=44
+PKG_RELEASE:=45
include $(INCLUDE_DIR)/package.mk
diff --git a/package/firewall/files/lib/fw.sh b/package/firewall/files/lib/fw.sh
index 0814ffc315..76e294f568 100644
--- a/package/firewall/files/lib/fw.sh
+++ b/package/firewall/files/lib/fw.sh
@@ -275,10 +275,7 @@ fw_check_icmptype4() {
export FW_ICMP4_TYPES=$(
iptables -p icmp -h 2>/dev/null | \
sed -n -e '/^Valid ICMP Types:/ {
- n; :r;
- /router-advertisement/d;
- /router-solicitation/d;
- s/[()]/ /g; s/[[:space:]]\+/\n/g; p; n; b r
+ n; :r; s/[()]/ /g; s/[[:space:]]\+/\n/g; p; n; b r
}' | sort -u
)