summaryrefslogtreecommitdiffstats
path: root/package/fconfig
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2008-05-27 13:21:12 +0000
committerImre Kaloz <kaloz@openwrt.org>2008-05-27 13:21:12 +0000
commit20fbb8b151613011ad3cbd37f9542ba0a0343ad1 (patch)
treec028c748ba725f1006565fd6d28b5145519aa589 /package/fconfig
parentc2619fb5ab1ae68ff39671c2286cec802c9343bc (diff)
downloadmaster-31e0f0ae-20fbb8b151613011ad3cbd37f9542ba0a0343ad1.tar.gz
master-31e0f0ae-20fbb8b151613011ad3cbd37f9542ba0a0343ad1.tar.bz2
master-31e0f0ae-20fbb8b151613011ad3cbd37f9542ba0a0343ad1.zip
move the fconfig package into trunk
SVN-Revision: 11274
Diffstat (limited to 'package/fconfig')
-rw-r--r--package/fconfig/Makefile46
1 files changed, 46 insertions, 0 deletions
diff --git a/package/fconfig/Makefile b/package/fconfig/Makefile
new file mode 100644
index 0000000000..3cc84998bc
--- /dev/null
+++ b/package/fconfig/Makefile
@@ -0,0 +1,46 @@
+#
+# Copyright (C) 2006-2008 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=fconfig
+PKG_VERSION:=20080329
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=http://andrzejekiert.ovh.org/software/fconfig/
+PKG_MD5SUM:=dac355e9f2a0f48c414c52e2034b6346
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)
+PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/fconfig
+ SECTION:=utils
+ CATEGORY:=Utilities
+ TITLE:=RedBoot configuration editor
+ URL:=http://andrzejekiert.ovh.org/software.html.en
+endef
+
+define Package/fconfig/description
+ displays and (if writable) also edits the RedBoot configuration.
+endef
+
+define Build/Configure
+endef
+
+define Build/Compile
+ $(call Build/Compile/Default)
+endef
+
+define Package/fconfig/install
+ $(INSTALL_DIR) $(1)/usr/sbin
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/fconfig $(1)/usr/sbin/
+endef
+
+$(eval $(call BuildPackage,fconfig))