summaryrefslogtreecommitdiffstats
path: root/package/dropbear
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2011-03-02 14:20:51 +0000
committerImre Kaloz <kaloz@openwrt.org>2011-03-02 14:20:51 +0000
commit9f803ade18f20220084d59123ada97b94f5c4935 (patch)
tree7ead952ce17140fc07153c688276f22c8a3f429b /package/dropbear
parent8c0df5f96c3b223009dd99ab3f2660c279984e91 (diff)
downloadmaster-31e0f0ae-9f803ade18f20220084d59123ada97b94f5c4935.tar.gz
master-31e0f0ae-9f803ade18f20220084d59123ada97b94f5c4935.tar.bz2
master-31e0f0ae-9f803ade18f20220084d59123ada97b94f5c4935.zip
upgrade to 0.53.1
SVN-Revision: 25830
Diffstat (limited to 'package/dropbear')
-rw-r--r--package/dropbear/Makefile9
-rw-r--r--package/dropbear/patches/110-change_user.patch6
-rw-r--r--package/dropbear/patches/120-use_small_code.patch11
-rw-r--r--package/dropbear/patches/130-ssh_ignore_o_and_x_args.patch4
4 files changed, 21 insertions, 9 deletions
diff --git a/package/dropbear/Makefile b/package/dropbear/Makefile
index bb1230cefc..9c6a2a2f2e 100644
--- a/package/dropbear/Makefile
+++ b/package/dropbear/Makefile
@@ -8,14 +8,14 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=dropbear
-PKG_VERSION:=0.52
-PKG_RELEASE:=5
+PKG_VERSION:=0.53.1
+PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:= \
http://matt.ucc.asn.au/dropbear/releases/ \
http://www.mirrors.wiretapped.net/security/cryptography/apps/ssh/dropbear/
-PKG_MD5SUM:=1c69ec674481d7745452f68f2ea5597e
+PKG_MD5SUM:=6b8d901859d9b8a18e2f6bfe0a892a03
PKG_BUILD_PARALLEL:=1
@@ -63,7 +63,8 @@ CONFIGURE_ARGS += \
--disable-loginfunc \
--disable-pututline \
--disable-pututxline \
- --disable-zlib
+ --disable-zlib \
+ --enable-bundled-libtom
TARGET_CFLAGS += -DARGTYPE=3 -ffunction-sections -fdata-sections
TARGET_LDFLAGS += -Wl,--gc-sections
diff --git a/package/dropbear/patches/110-change_user.patch b/package/dropbear/patches/110-change_user.patch
index 964229bd74..f003c276cf 100644
--- a/package/dropbear/patches/110-change_user.patch
+++ b/package/dropbear/patches/110-change_user.patch
@@ -1,6 +1,6 @@
--- a/svr-chansession.c
+++ b/svr-chansession.c
-@@ -852,12 +852,12 @@ static void execchild(void *user_data) {
+@@ -881,12 +881,12 @@ static void execchild(void *user_data) {
/* We can only change uid/gid as root ... */
if (getuid() == 0) {
@@ -9,10 +9,10 @@
(initgroups(ses.authstate.pw_name,
- ses.authstate.pw_gid) < 0)) {
+ ses.authstate.pw_gid) < 0))) {
- dropbear_exit("error changing user group");
+ dropbear_exit("Error changing user group");
}
- if (setuid(ses.authstate.pw_uid) < 0) {
+ if ((ses.authstate.pw_uid != 0) && (setuid(ses.authstate.pw_uid) < 0)) {
- dropbear_exit("error changing user");
+ dropbear_exit("Error changing user");
}
} else {
diff --git a/package/dropbear/patches/120-use_small_code.patch b/package/dropbear/patches/120-use_small_code.patch
new file mode 100644
index 0000000000..98a760fab7
--- /dev/null
+++ b/package/dropbear/patches/120-use_small_code.patch
@@ -0,0 +1,11 @@
+--- a/options.h
++++ b/options.h
+@@ -49,7 +49,7 @@
+ several kB in binary size however will make the symmetrical ciphers and hashes
+ slower, perhaps by 50%. Recommended for small systems that aren't doing
+ much traffic. */
+-/*#define DROPBEAR_SMALL_CODE*/
++#define DROPBEAR_SMALL_CODE
+
+ /* Enable X11 Forwarding - server only */
+ #define ENABLE_X11FWD
diff --git a/package/dropbear/patches/130-ssh_ignore_o_and_x_args.patch b/package/dropbear/patches/130-ssh_ignore_o_and_x_args.patch
index 7c4306c368..93647a99e5 100644
--- a/package/dropbear/patches/130-ssh_ignore_o_and_x_args.patch
+++ b/package/dropbear/patches/130-ssh_ignore_o_and_x_args.patch
@@ -1,6 +1,6 @@
--- a/cli-runopts.c
+++ b/cli-runopts.c
-@@ -271,6 +271,10 @@ void cli_getopts(int argc, char ** argv)
+@@ -287,6 +287,10 @@ void cli_getopts(int argc, char ** argv)
debug_trace = 1;
break;
#endif
@@ -11,7 +11,7 @@
case 'F':
case 'e':
case 'c':
-@@ -282,7 +286,6 @@ void cli_getopts(int argc, char ** argv)
+@@ -298,7 +302,6 @@ void cli_getopts(int argc, char ** argv)
#ifndef ENABLE_CLI_LOCALTCPFWD
case 'L':
#endif