summaryrefslogtreecommitdiffstats
path: root/package/dropbear/Makefile
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2009-02-03 22:28:16 +0000
committerFlorian Fainelli <florian@openwrt.org>2009-02-03 22:28:16 +0000
commita377aa9ab534ed8fbbc6bbd867bfd66566da73ce (patch)
tree1524bfc4ecb86f4e12f4842dcf20e64fe4675bd1 /package/dropbear/Makefile
parent59ff6c01d8581b8b787d6df3580bdcce96f17625 (diff)
downloadmaster-31e0f0ae-a377aa9ab534ed8fbbc6bbd867bfd66566da73ce.tar.gz
master-31e0f0ae-a377aa9ab534ed8fbbc6bbd867bfd66566da73ce.tar.bz2
master-31e0f0ae-a377aa9ab534ed8fbbc6bbd867bfd66566da73ce.zip
add dropkey ssh keys and config files to the conffiles section (#2014)
SVN-Revision: 14399
Diffstat (limited to 'package/dropbear/Makefile')
-rw-r--r--package/dropbear/Makefile11
1 files changed, 9 insertions, 2 deletions
diff --git a/package/dropbear/Makefile b/package/dropbear/Makefile
index a98c24aa2a..5943fc62c0 100644
--- a/package/dropbear/Makefile
+++ b/package/dropbear/Makefile
@@ -35,6 +35,12 @@ define Package/dropbear/description
A small SSH2 server/client designed for small memory environments.
endef
+define Package/dropbear/conffiles
+/etc/dropbear/dropbear_rsa_host_key
+/etc/dropbear/dropbear_dss_host_key
+/etc/config/dropbear
+endef
+
define Package/dropbearconvert
$(call Package/dropbear/Default)
SECTION:=utils
@@ -89,8 +95,9 @@ define Package/dropbear/install
$(INSTALL_DIR) $(1)/etc/init.d
$(INSTALL_BIN) ./files/dropbear.init $(1)/etc/init.d/dropbear
$(INSTALL_DIR) $(1)/usr/lib/opkg/info
- echo /etc/dropbear/dropbear_rsa_host_key > $(1)/usr/lib/opkg/info/dropbear.conffiles
- echo /etc/dropbear/dropbear_dss_host_key >> $(1)/usr/lib/opkg/info/dropbear.conffiles
+ $(INSTALL_DIR) $(1)/etc/dropbear
+ touch $(1)/etc/dropbear/dropbear_rsa_host_key
+ touch $(1)/etc/dropbear/dropbear_dss_host_key
endef
define Package/dropbearconvert/install