summaryrefslogtreecommitdiffstats
path: root/package/dropbear/Makefile
diff options
context:
space:
mode:
authorMichael Büsch <mb@bu3sch.de>2010-09-07 10:00:34 +0000
committerMichael Büsch <mb@bu3sch.de>2010-09-07 10:00:34 +0000
commit7b30b70e11b8a7e90eddaa33468118bf1628a3ca (patch)
tree83f13b82bd305caf5d1c3d31f931ae8099eaf603 /package/dropbear/Makefile
parentf54f9b25e1ecc50501e99d0c83843cccbc071f01 (diff)
downloadmaster-31e0f0ae-7b30b70e11b8a7e90eddaa33468118bf1628a3ca.tar.gz
master-31e0f0ae-7b30b70e11b8a7e90eddaa33468118bf1628a3ca.tar.bz2
master-31e0f0ae-7b30b70e11b8a7e90eddaa33468118bf1628a3ca.zip
From: Joseph Roback <openwrt-devel@roback.cc>
26 Makefile patches for enabling parallel builds. Tested on Linux (8-core) and Darwin (12-core), individually and from clean build_root. The first set is from trunk, the second is from feeds/packages. Signed-off-by: Joe Roback <joe@roback.cc> SVN-Revision: 22965
Diffstat (limited to 'package/dropbear/Makefile')
-rw-r--r--package/dropbear/Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/package/dropbear/Makefile b/package/dropbear/Makefile
index 77d6d9707b..6fad273660 100644
--- a/package/dropbear/Makefile
+++ b/package/dropbear/Makefile
@@ -17,6 +17,8 @@ PKG_SOURCE_URL:= \
http://www.mirrors.wiretapped.net/security/cryptography/apps/ssh/dropbear/
PKG_MD5SUM:=1c69ec674481d7745452f68f2ea5597e
+PKG_BUILD_PARALLEL:=1
+
include $(INCLUDE_DIR)/package.mk
define Package/dropbear/Default
@@ -70,12 +72,12 @@ define Build/Configure
endef
define Build/Compile
- $(MAKE) -C $(PKG_BUILD_DIR) \
+ $(MAKE) $(PKG_JOBS) -C $(PKG_BUILD_DIR) \
$(TARGET_CONFIGURE_OPTS) \
LD="$(TARGET_CC)" \
PROGRAMS="dropbear dbclient dropbearkey scp" \
MULTI=1 SCPPROGRESS=1
- $(MAKE) -C $(PKG_BUILD_DIR) \
+ $(MAKE) $(PKG_JOBS) -C $(PKG_BUILD_DIR) \
$(TARGET_CONFIGURE_OPTS) \
LD="$(TARGET_CC)" \
PROGRAMS="dropbearconvert"