summaryrefslogtreecommitdiffstats
path: root/package/devel
diff options
context:
space:
mode:
authorYousong Zhou <yszhou4tech@gmail.com>2016-06-09 10:04:24 +0800
committerJohn Crispin <john@phrozen.org>2016-06-13 22:51:43 +0200
commit8bd02b1381f1f660ad6621f908dbf3fca556a24c (patch)
tree4d4e6a185afbce9efa43e97fa0284f6eb14fff76 /package/devel
parent987f14ab2343ae32bbeaa02fbdc34dfb235f8f7c (diff)
downloadmaster-31e0f0ae-8bd02b1381f1f660ad6621f908dbf3fca556a24c.tar.gz
master-31e0f0ae-8bd02b1381f1f660ad6621f908dbf3fca556a24c.tar.bz2
master-31e0f0ae-8bd02b1381f1f660ad6621f908dbf3fca556a24c.zip
strace: add option for enabling stack trace support
Signed-off-by: Yousong Zhou <yszhou4tech@gmail.com>
Diffstat (limited to 'package/devel')
-rw-r--r--package/devel/strace/Makefile11
1 files changed, 10 insertions, 1 deletions
diff --git a/package/devel/strace/Makefile b/package/devel/strace/Makefile
index 8a0d2e8fb3..df560fd1b7 100644
--- a/package/devel/strace/Makefile
+++ b/package/devel/strace/Makefile
@@ -11,7 +11,7 @@ include $(INCLUDE_DIR)/kernel.mk
PKG_NAME:=strace
PKG_VERSION:=4.11
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_MD5SUM:=a15d2555a7febb56d00c6e1a51c655dc
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
@@ -23,6 +23,7 @@ PKG_LICENSE_FILES:=COPYRIGHT
PKG_MAINTAINER:=Felix Fietkau <nbd@nbd.name>
PKG_FIXUP:=autoreconf
+PKG_CONFIG_DEPENDS:=CONFIG_PACKAGE_strace_libunwind
PKG_INSTALL:=1
include $(INCLUDE_DIR)/package.mk
@@ -39,6 +40,7 @@ define Package/strace
SECTION:=utils
CATEGORY:=Utilities
TITLE:=System call tracer
+ DEPENDS:=+PACKAGE_strace_libunwind:libunwind
URL:=http://strace.sourceforge.net/
endef
@@ -47,6 +49,13 @@ A useful diagnostic, instructional, and debugging tool. Allows you to track what
system calls a program makes while it is running.
endef
+define Package/strace/config
+config PACKAGE_strace_libunwind
+ bool "Enable stack tracing support using libunwind (experimental)"
+ default n
+endef
+
+CONFIGURE_ARGS += --with-libunwind=$(if $(CONFIG_PACKAGE_strace_libunwind),yes,no)
MAKE_FLAGS := \
CCOPT="$(TARGET_CFLAGS)"