summaryrefslogtreecommitdiffstats
path: root/package/devel
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2014-10-19 22:49:42 +0000
committerFelix Fietkau <nbd@openwrt.org>2014-10-19 22:49:42 +0000
commit338892ddf82e2e07bc7512ca88cc44927b950dfe (patch)
tree7fc22b44aed8d208e06911d1a8cdbf30e8fc3f20 /package/devel
parent35232039c0d3b21e40d447970784e464604e3e8a (diff)
downloadmaster-31e0f0ae-338892ddf82e2e07bc7512ca88cc44927b950dfe.tar.gz
master-31e0f0ae-338892ddf82e2e07bc7512ca88cc44927b950dfe.tar.bz2
master-31e0f0ae-338892ddf82e2e07bc7512ca88cc44927b950dfe.zip
gdb: update to version 7.8, fix musl build
Signed-off-by: Felix Fietkau <nbd@openwrt.org> SVN-Revision: 42979
Diffstat (limited to 'package/devel')
-rw-r--r--package/devel/gdb/Makefile6
-rw-r--r--package/devel/gdb/patches/001-gdb-pr14523-mips-signal-number.patch6
-rw-r--r--package/devel/gdb/patches/100-musl_fix.patch28
3 files changed, 34 insertions, 6 deletions
diff --git a/package/devel/gdb/Makefile b/package/devel/gdb/Makefile
index 7663188914..359a11be2b 100644
--- a/package/devel/gdb/Makefile
+++ b/package/devel/gdb/Makefile
@@ -8,12 +8,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=gdb
-PKG_VERSION:=7.5
+PKG_VERSION:=7.8
PKG_RELEASE:=1
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=@GNU/gdb
-PKG_MD5SUM:=24a6779a9fe0260667710de1b082ef61
+PKG_MD5SUM:=bd958fe9019d7c7896f29f6724a764ed
PKG_BUILD_PARALLEL:=1
PKG_INSTALL:=1
diff --git a/package/devel/gdb/patches/001-gdb-pr14523-mips-signal-number.patch b/package/devel/gdb/patches/001-gdb-pr14523-mips-signal-number.patch
index c462399bb5..6b324a32af 100644
--- a/package/devel/gdb/patches/001-gdb-pr14523-mips-signal-number.patch
+++ b/package/devel/gdb/patches/001-gdb-pr14523-mips-signal-number.patch
@@ -1,8 +1,8 @@
See http://sourceware.org/bugzilla/show_bug.cgi?id=14523
---
---- gdb-7.5.org/gdb/common/signals.c 2012-05-24 18:51:37.000000000 +0200
-+++ gdb-7.5.org/gdb/common/signals.c 2012-08-29 22:32:07.000000000 +0200
-@@ -346,6 +346,11 @@
+--- a/gdb/common/signals.c
++++ b/gdb/common/signals.c
+@@ -350,6 +350,11 @@ gdb_signal_from_host (int hostsig)
else if (64 <= hostsig && hostsig <= 127)
return (enum gdb_signal)
(hostsig - 64 + (int) GDB_SIGNAL_REALTIME_64);
diff --git a/package/devel/gdb/patches/100-musl_fix.patch b/package/devel/gdb/patches/100-musl_fix.patch
new file mode 100644
index 0000000000..d6dd7a01c5
--- /dev/null
+++ b/package/devel/gdb/patches/100-musl_fix.patch
@@ -0,0 +1,28 @@
+--- a/gdb/linux-nat.c
++++ b/gdb/linux-nat.c
+@@ -17,6 +17,7 @@
+ You should have received a copy of the GNU General Public License
+ along with this program. If not, see <http://www.gnu.org/licenses/>. */
+
++#include "stopcode.h"
+ #include "defs.h"
+ #include "inferior.h"
+ #include "infrun.h"
+@@ -81,6 +82,10 @@
+ # endif
+ #endif /* HAVE_PERSONALITY */
+
++#ifndef __SIGRTMIN
++#define __SIGRTMIN SIGRTMIN
++#endif
++
+ /* This comment documents high-level logic of this file.
+
+ Waiting for events in sync mode
+--- /dev/null
++++ b/gdb/stopcode.h
+@@ -0,0 +1,4 @@
++#ifndef W_STOPCODE
++#define W_STOPCODE(sig) ((sig) << 8 | 0x7f)
++#endif
++