summaryrefslogtreecommitdiffstats
path: root/package/devel/gdb
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2014-10-24 11:19:29 +0000
committerNicolas Thill <nico@openwrt.org>2014-10-24 11:19:29 +0000
commit7e2e5ff6756bff3d7a9bcc6a064c43605d1110c4 (patch)
tree6a249f20ea93a6a1a001a390a3e30506b4830c50 /package/devel/gdb
parent4de4827ddc9d64a055bcfdb6a65f0e427d36e85e (diff)
downloadmaster-31e0f0ae-7e2e5ff6756bff3d7a9bcc6a064c43605d1110c4.tar.gz
master-31e0f0ae-7e2e5ff6756bff3d7a9bcc6a064c43605d1110c4.tar.bz2
master-31e0f0ae-7e2e5ff6756bff3d7a9bcc6a064c43605d1110c4.zip
gdb: fix build failure on arm
Signed-off-by: Nicolas Thill <nico@openwrt.org> SVN-Revision: 43042
Diffstat (limited to 'package/devel/gdb')
-rw-r--r--package/devel/gdb/patches/101-arm-uclibc-sim-needs-libm.patch22
1 files changed, 22 insertions, 0 deletions
diff --git a/package/devel/gdb/patches/101-arm-uclibc-sim-needs-libm.patch b/package/devel/gdb/patches/101-arm-uclibc-sim-needs-libm.patch
new file mode 100644
index 0000000000..c3c99d22cd
--- /dev/null
+++ b/package/devel/gdb/patches/101-arm-uclibc-sim-needs-libm.patch
@@ -0,0 +1,22 @@
+This patch fixes a build error on arm:
+
+arm-openwrt-linux-uclibcgnueabi-gcc -DHAVE_CONFIG_H -DPROFILE=1 -DWITH_PROFILE=-1 -DDEFAULT_INLINE=0 -DMODET -DNEED_UI_LOOP_HOOK -DSIM_TARGET_SWITCHES -I. -I. -I../common -I./../common -I../../include -I./../../include -I../../bfd -I./../../bfd -I../../opcodes -I./../../opcodes -Os -pipe -march=armv7-a -mtune=cortex-a8 -mfpu=vfpv3-d16 -fno-caller-saves -fhonour-copts -Wno-error=unused-but-set-variable -mfloat-abi=hard -static-libstdc++ -static-libgcc -L/fun/Projects/OpenWrt/dev/openwrt-core-2/staging_dir/target-arm_cortex-a8+vfpv3_uClibc-0.9.33.2_eabi/usr/lib -L/fun/Projects/OpenWrt/dev/openwrt-core-2/staging_dir/target-arm_cortex-a8+vfpv3_uClibc-0.9.33.2_eabi/lib -L/fun/Projects/OpenWrt/dev/openwrt-core-2/staging_dir/toolchain-arm_cortex-a8+vfpv3_gcc-4.8-linaro_uClibc-0.9.33.2_eabi/usr/lib -L/fun/Projects/OpenWrt/dev/openwrt-core-2/staging_dir/toolchain-arm_cortex-a8+vfpv3_gcc-4.8-linaro_uClibc-0.9.33.2_eabi/lib -o run \
+ run.o libsim.a ../../bfd/libbfd.a ../../opcodes/libopcodes.a ../../libiberty/libiberty.a -lz -lnsl
+../../libiberty/libiberty.a(floatformat.o): In function `floatformat_to_double':
+floatformat.c:(.text+0x454): undefined reference to `ldexp'
+floatformat.c:(.text+0x4a4): undefined reference to `ldexp'
+../../libiberty/libiberty.a(floatformat.o): In function `floatformat_from_double':
+floatformat.c:(.text+0x5dc): undefined reference to `frexp'
+floatformat.c:(.text+0x644): undefined reference to `ldexp'
+collect2: error: ld returned 1 exit status
+
+--- a/sim/arm/Makefile.in
++++ b/sim/arm/Makefile.in
+@@ -18,6 +18,7 @@
+ ## COMMON_PRE_CONFIG_FRAG
+
+ SIM_EXTRA_CFLAGS = -DMODET -DNEED_UI_LOOP_HOOK -DSIM_TARGET_SWITCHES
++SIM_EXTRA_LIBS = -lm
+
+ COPRO=@COPRO@
+