summaryrefslogtreecommitdiffstats
path: root/package/busybox
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-04-04 16:11:28 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-04-04 16:11:28 +0000
commit523fe3cf87d70bc0de2379dad8b03cf62ab86e49 (patch)
treecfdcfcdbd1557814428dba37d432de06780205f0 /package/busybox
parent604782648ad588e1fda16ed8c6b750b8c988a4a3 (diff)
downloadmaster-31e0f0ae-523fe3cf87d70bc0de2379dad8b03cf62ab86e49.tar.gz
master-31e0f0ae-523fe3cf87d70bc0de2379dad8b03cf62ab86e49.tar.bz2
master-31e0f0ae-523fe3cf87d70bc0de2379dad8b03cf62ab86e49.zip
replace gen_busybox_config.pl with a simple sed command
SVN-Revision: 6864
Diffstat (limited to 'package/busybox')
-rw-r--r--package/busybox/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/busybox/Makefile b/package/busybox/Makefile
index 90e3af060a..03a0ebd549 100644
--- a/package/busybox/Makefile
+++ b/package/busybox/Makefile
@@ -51,7 +51,7 @@ endef
define Build/Configure
rm -f $(PKG_BUILD_DIR)/.configured*
- $(SCRIPT_DIR)/gen_busybox_config.pl $(TOPDIR)/.config > $(PKG_BUILD_DIR)/.config
+ grep 'CONFIG_BUSYBOX_' $(TOPDIR)/.config | sed -e "s,\\(# \)\\?CONFIG_BUSYBOX_\\(.*\\),\\1\\2,g" > $(PKG_BUILD_DIR)/.config
yes '' | $(MAKE) -C $(PKG_BUILD_DIR) \
CC="$(TARGET_CC)" \
CROSS_COMPILE="$(TARGET_CROSS)" \