summaryrefslogtreecommitdiffstats
path: root/package/broadcom-wl/src/wlcompat/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-11-10 19:00:53 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-11-10 19:00:53 +0000
commit2ab260e917ee2ffa4d215aac2c7be093d48f76d2 (patch)
treea26d476a214d27594df0180d204337fbd9f067a0 /package/broadcom-wl/src/wlcompat/Makefile
parent4db640a50331fff2b661a4109b430ad056ccbcdc (diff)
downloadmaster-31e0f0ae-2ab260e917ee2ffa4d215aac2c7be093d48f76d2.tar.gz
master-31e0f0ae-2ab260e917ee2ffa4d215aac2c7be093d48f76d2.tar.bz2
master-31e0f0ae-2ab260e917ee2ffa4d215aac2c7be093d48f76d2.zip
move wlcompat to the broadcom-wl package
SVN-Revision: 9528
Diffstat (limited to 'package/broadcom-wl/src/wlcompat/Makefile')
-rw-r--r--package/broadcom-wl/src/wlcompat/Makefile25
1 files changed, 25 insertions, 0 deletions
diff --git a/package/broadcom-wl/src/wlcompat/Makefile b/package/broadcom-wl/src/wlcompat/Makefile
new file mode 100644
index 0000000000..6f3224df14
--- /dev/null
+++ b/package/broadcom-wl/src/wlcompat/Makefile
@@ -0,0 +1,25 @@
+# $Id$
+#
+# Makefile for wlcompat
+#
+# Copyright (C) 2005-2007 Felix Fietkau <nbd@openwrt.org>
+#
+# This program is free software; you can redistribute it and/or
+# modify it under the terms of the GNU General Public License
+# as published by the Free Software Foundation; either version
+# 2 of the License, or (at your option) any later version.
+#
+
+EXTRA_CFLAGS += -DBCMDRIVER=1 -DBCMDMA64=1 -I../include
+ifneq ($(DEBUG),)
+ EXTRA_CFLAGS += -DDEBUG=1
+ _D=-debug
+endif
+
+obj-m := wlcompat$(_D).o
+modules: wlcompat$(_D).o
+
+wlcompat$(_D).o: wlcompat.c
+ $(CC) $(CFLAGS) $(EXTRA_CFLAGS_nostdinc) -DKBUILD_BASENAME=$(subst $(comma),_,$(subst -,_,$(*F))) $(CFLAGS_$@) -c -o $@ $<
+
+-include $(TOPDIR)/Rules.make