summaryrefslogtreecommitdiffstats
path: root/package/broadcom-wl/patches
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2010-07-01 01:06:32 +0000
committerJo-Philipp Wich <jow@openwrt.org>2010-07-01 01:06:32 +0000
commit28e4d39009b5f4b82415e437aef7ea24683fefe4 (patch)
tree0cc441c0ee5d851cf353a04adc1b9832acd96efa /package/broadcom-wl/patches
parentd6d8014cfd0fc8ce789d03f882bdce0745fa52e7 (diff)
downloadmaster-31e0f0ae-28e4d39009b5f4b82415e437aef7ea24683fefe4.tar.gz
master-31e0f0ae-28e4d39009b5f4b82415e437aef7ea24683fefe4.tar.bz2
master-31e0f0ae-28e4d39009b5f4b82415e437aef7ea24683fefe4.zip
broadcom-wl: - fix compilation against eglibc and glibc (#7521) - unbind device from b43 ssb bridge on boot (#7529)
SVN-Revision: 22007
Diffstat (limited to 'package/broadcom-wl/patches')
-rw-r--r--package/broadcom-wl/patches/002-ctype.patch30
1 files changed, 30 insertions, 0 deletions
diff --git a/package/broadcom-wl/patches/002-ctype.patch b/package/broadcom-wl/patches/002-ctype.patch
new file mode 100644
index 0000000000..16d13df30c
--- /dev/null
+++ b/package/broadcom-wl/patches/002-ctype.patch
@@ -0,0 +1,30 @@
+--- a/shared/Makefile
++++ b/shared/Makefile
+@@ -19,7 +19,7 @@ LDFLAGS += -L.
+ AR=ar
+ RANLIB=ranlib
+
+-OBJS := shutils.o wl.o wl_linux.o linux_timer.o
++OBJS := shutils.o wl.o wl_linux.o linux_timer.o ctype.o
+ all: libshared.a
+
+ clean:
+--- /dev/null
++++ b/shared/ctype.c
+@@ -0,0 +1,16 @@
++#include <features.h>
++
++#ifndef __UCLIBC__
++extern void **__ctype_b_loc();
++extern void **__ctype_tolower_loc();
++
++void *__ctype_b;
++void *__ctype_tolower;
++
++static void init(void) __attribute__((constructor));
++static void init(void)
++{
++ __ctype_b = *__ctype_b_loc();
++ __ctype_tolower = *__ctype_tolower_loc();
++}
++#endif