summaryrefslogtreecommitdiffstats
path: root/package/boot
diff options
context:
space:
mode:
authorLuka Perkov <luka@openwrt.org>2016-03-25 12:07:03 +0000
committerLuka Perkov <luka@openwrt.org>2016-03-25 12:07:03 +0000
commitd1aa4bfe1ddd52c52eb6314155245121078399a1 (patch)
tree877832072963cb166bb42d000421a09a1a996bfa /package/boot
parent8258f8edb60e0ee7f1518bf44696d9a6b846d524 (diff)
downloadmaster-31e0f0ae-d1aa4bfe1ddd52c52eb6314155245121078399a1.tar.gz
master-31e0f0ae-d1aa4bfe1ddd52c52eb6314155245121078399a1.tar.bz2
master-31e0f0ae-d1aa4bfe1ddd52c52eb6314155245121078399a1.zip
uboot-mvebu: add package
Signed-off-by: Andrej Vlasic <andrej.vlasic@sartura.hr> Signed-off-by: Vladimir Vid <vladimir.vid@sartura.hr> SVN-Revision: 49088
Diffstat (limited to 'package/boot')
-rw-r--r--package/boot/uboot-mvebu/Makefile91
-rw-r--r--package/boot/uboot-mvebu/patches/001-use-dtc-in-kernel.patch11
2 files changed, 102 insertions, 0 deletions
diff --git a/package/boot/uboot-mvebu/Makefile b/package/boot/uboot-mvebu/Makefile
new file mode 100644
index 0000000000..170da6d235
--- /dev/null
+++ b/package/boot/uboot-mvebu/Makefile
@@ -0,0 +1,91 @@
+#
+# Copyright (C) 2016 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+include $(INCLUDE_DIR)/kernel.mk
+
+PKG_NAME:=u-boot
+PKG_VERSION:=2016.03
+PKG_RELEASE:=1
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(BUILD_VARIANT)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_SOURCE_URL:=\
+ http://mirror2.openwrt.org/sources \
+ ftp://ftp.denx.de/pub/u-boot
+PKG_MD5SUM:=973c1d896be751321cc3aafa564f64b2
+
+PKG_LICENSE:=GPL-2.0 GPL-2.0+
+PKG_LICENSE_FILES:=Licenses/README
+
+PKG_BUILD_PARALLEL:=1
+
+include $(INCLUDE_DIR)/package.mk
+
+define uboot/Default
+ TITLE:=
+endef
+
+define uboot/clearfog
+ TITLE:=U-Boot for SolidRun ClearFog A1
+endef
+
+UBOOTS:= \
+ clearfog
+
+define Package/uboot/template
+define Package/uboot-mvebu-$(1)
+ SECTION:=boot
+ CATEGORY:=Boot Loaders
+ DEPENDS:=@TARGET_mvebu
+ TITLE:=$(2)
+ URL:=http://www.denx.de/wiki/U-Boot
+ VARIANT:=$(1)
+ MAINTAINER:=Luka Perkov <luka@openwrt.org>
+endef
+endef
+
+define BuildUBootPackage
+ $(eval $(uboot/Default))
+ $(eval $(uboot/$(1)))
+ $(call Package/uboot/template,$(1),$(TITLE))
+endef
+
+define Build/Configure
+ +$(MAKE) $(PKG_JOBS) -C $(PKG_BUILD_DIR) \
+ $(BUILD_VARIANT)_config
+endef
+
+define Build/Compile
+ +$(MAKE) $(PKG_JOBS) -C $(PKG_BUILD_DIR) \
+ CROSS_COMPILE=$(TARGET_CROSS) \
+ DTC_DIR=$(LINUX_DIR)/scripts/dtc/
+endef
+
+define Package/uboot/install/default
+ $(INSTALL_DIR) $(BIN_DIR)/uboot-$(BOARD)-$(1)
+ $(CP) $(PKG_BUILD_DIR)/u-boot-spl.kwb \
+ $(BIN_DIR)/uboot-$(BOARD)-$(1)/openwrt-$(BOARD)-$(1)-u-boot-spl.kwb
+ $(INSTALL_DIR) $(BIN_DIR)/u-boot-kwboot/
+ $(CP) $(PKG_BUILD_DIR)/tools/kwboot \
+ $(BIN_DIR)/u-boot-kwboot/
+endef
+
+define Package/uboot/install/template
+define Package/uboot-mvebu-$(1)/install
+ $(call Package/uboot/install/default,$(2))
+endef
+endef
+
+$(foreach u,$(UBOOTS), \
+ $(eval $(call Package/uboot/install/template,$(u),$(u))) \
+)
+
+$(foreach u,$(UBOOTS), \
+ $(eval $(call BuildUBootPackage,$(u))) \
+ $(eval $(call BuildPackage,uboot-mvebu-$(u))) \
+)
diff --git a/package/boot/uboot-mvebu/patches/001-use-dtc-in-kernel.patch b/package/boot/uboot-mvebu/patches/001-use-dtc-in-kernel.patch
new file mode 100644
index 0000000000..7e46084ad8
--- /dev/null
+++ b/package/boot/uboot-mvebu/patches/001-use-dtc-in-kernel.patch
@@ -0,0 +1,11 @@
+--- a/Makefile
++++ b/Makefile
+@@ -348,7 +348,7 @@ OBJDUMP = $(CROSS_COMPILE)objdump
+ AWK = awk
+ PERL = perl
+ PYTHON = python
+-DTC = dtc
++DTC = $(DTC_DIR)dtc
+ CHECK = sparse
+
+ CHECKFLAGS := -D__linux__ -Dlinux -D__STDC__ -Dunix -D__unix__ \