summaryrefslogtreecommitdiffstats
path: root/package/boot
diff options
context:
space:
mode:
authorZoltan Herpai <wigyori@uid0.hu>2015-09-18 19:29:23 +0000
committerZoltan Herpai <wigyori@uid0.hu>2015-09-18 19:29:23 +0000
commita1f41646314a76173ff1dcac35d09431357183da (patch)
treec13458c001626e4ef0c346747fde88ad5c215724 /package/boot
parentc927366d05d9b1a0ef7a9e6a0d9ebce278033ea1 (diff)
downloadmaster-31e0f0ae-a1f41646314a76173ff1dcac35d09431357183da.tar.gz
master-31e0f0ae-a1f41646314a76173ff1dcac35d09431357183da.tar.bz2
master-31e0f0ae-a1f41646314a76173ff1dcac35d09431357183da.zip
packages: uboot-mxs: place binaries in the designated path
Signed-off-by: Michael Heimpold <mhei@heimpold.de> SVN-Revision: 47008
Diffstat (limited to 'package/boot')
-rw-r--r--package/boot/uboot-mxs/Makefile6
1 files changed, 2 insertions, 4 deletions
diff --git a/package/boot/uboot-mxs/Makefile b/package/boot/uboot-mxs/Makefile
index 1686f60a18..a6a137ce43 100644
--- a/package/boot/uboot-mxs/Makefile
+++ b/package/boot/uboot-mxs/Makefile
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2013 OpenWrt.org
+# Copyright (C) 2013-2015 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -40,7 +40,6 @@ endef
UBOOTS := \
mx23_olinuxino \
duckbill
-
define Package/uboot/template
define Package/uboot-mxs-$(1)
@@ -76,10 +75,9 @@ define Build/Compile
CROSS_COMPILE=$(TARGET_CROSS) u-boot.sb
endef
-
define Package/uboot/install/default
$(INSTALL_DIR) $(BIN_DIR)/uboot-$(BOARD)-$(1)
- dd if=$(PKG_BUILD_DIR)/u-boot.sb of=$(BIN_DIR)/uboot-$(BOARD)-$(1).sb bs=512 seek=4
+ dd if=$(PKG_BUILD_DIR)/u-boot.sb of=$(BIN_DIR)/uboot-$(BOARD)-$(1)/uboot-$(BOARD)-$(1).sb bs=512 seek=4
endef
define Package/uboot/install/template