summaryrefslogtreecommitdiffstats
path: root/package/boot
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@hauke-m.de>2015-11-20 21:15:48 +0000
committerHauke Mehrtens <hauke@hauke-m.de>2015-11-20 21:15:48 +0000
commit4afee425600a5cdc22666ae37afaafdb1a6b9b2b (patch)
treee51ae5c573a2b20b5d933131eea1f69a474c80e5 /package/boot
parent8d8ef5288cdb914ded16d9f81c85b0144fda074a (diff)
downloadmaster-31e0f0ae-4afee425600a5cdc22666ae37afaafdb1a6b9b2b.tar.gz
master-31e0f0ae-4afee425600a5cdc22666ae37afaafdb1a6b9b2b.tar.bz2
master-31e0f0ae-4afee425600a5cdc22666ae37afaafdb1a6b9b2b.zip
uboot-mxs: fix build with gcc-5
gcc-5 handles inline without static differently and that makes uboot-mxs fail to build. Remove the inline so it gets exported and can be used in other functions. Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de> SVN-Revision: 47533
Diffstat (limited to 'package/boot')
-rw-r--r--package/boot/uboot-mxs/patches/001-add-i2se-duckbill.patch30
-rw-r--r--package/boot/uboot-mxs/patches/100-gcc-5-fix.patch11
2 files changed, 12 insertions, 29 deletions
diff --git a/package/boot/uboot-mxs/patches/001-add-i2se-duckbill.patch b/package/boot/uboot-mxs/patches/001-add-i2se-duckbill.patch
index f410b19b87..79138d227f 100644
--- a/package/boot/uboot-mxs/patches/001-add-i2se-duckbill.patch
+++ b/package/boot/uboot-mxs/patches/001-add-i2se-duckbill.patch
@@ -23,8 +23,6 @@ Signed-off-by: Michael Heimpold <mhei@heimpold.de>
create mode 100644 configs/duckbill_defconfig
create mode 100644 include/configs/duckbill.h
-diff --git a/arch/arm/Kconfig b/arch/arm/Kconfig
-index 9908b43..7c795ac 100644
--- a/arch/arm/Kconfig
+++ b/arch/arm/Kconfig
@@ -178,6 +178,11 @@ config TARGET_MX28EVK
@@ -39,7 +37,7 @@ index 9908b43..7c795ac 100644
config TARGET_MX23_OLINUXINO
bool "Support mx23_olinuxino"
select CPU_ARM926EJS
-@@ -926,6 +931,7 @@ source "board/genesi/mx51_efikamx/Kconfig"
+@@ -926,6 +931,7 @@ source "board/genesi/mx51_efikamx/Kconfi
source "board/gumstix/pepper/Kconfig"
source "board/h2200/Kconfig"
source "board/hale/tt01/Kconfig"
@@ -47,8 +45,6 @@ index 9908b43..7c795ac 100644
source "board/icpdas/lp8x4x/Kconfig"
source "board/imx31_phycore/Kconfig"
source "board/isee/igep0033/Kconfig"
-diff --git a/arch/arm/include/asm/mach-types.h b/arch/arm/include/asm/mach-types.h
-index 5afe791..330a88d 100644
--- a/arch/arm/include/asm/mach-types.h
+++ b/arch/arm/include/asm/mach-types.h
@@ -1109,6 +1109,7 @@ extern unsigned int __machine_arch_type;
@@ -78,9 +74,6 @@ index 5afe791..330a88d 100644
/*
* These have not yet been registered
*/
-diff --git a/board/i2se/duckbill/Kconfig b/board/i2se/duckbill/Kconfig
-new file mode 100644
-index 0000000..98c1e46
--- /dev/null
+++ b/board/i2se/duckbill/Kconfig
@@ -0,0 +1,15 @@
@@ -99,9 +92,6 @@ index 0000000..98c1e46
+ default "duckbill"
+
+endif
-diff --git a/board/i2se/duckbill/MAINTAINERS b/board/i2se/duckbill/MAINTAINERS
-new file mode 100644
-index 0000000..5496baa
--- /dev/null
+++ b/board/i2se/duckbill/MAINTAINERS
@@ -0,0 +1,6 @@
@@ -111,9 +101,6 @@ index 0000000..5496baa
+F: board/i2se/duckbill/
+F: include/configs/duckbill.h
+F: configs/duckbill_defconfig
-diff --git a/board/i2se/duckbill/Makefile b/board/i2se/duckbill/Makefile
-new file mode 100644
-index 0000000..b5577e3
--- /dev/null
+++ b/board/i2se/duckbill/Makefile
@@ -0,0 +1,12 @@
@@ -129,9 +116,6 @@ index 0000000..b5577e3
+else
+obj-y := iomux.o
+endif
-diff --git a/board/i2se/duckbill/duckbill.c b/board/i2se/duckbill/duckbill.c
-new file mode 100644
-index 0000000..7794f65
--- /dev/null
+++ b/board/i2se/duckbill/duckbill.c
@@ -0,0 +1,112 @@
@@ -247,9 +231,6 @@ index 0000000..7794f65
+
+ return 0;
+}
-diff --git a/board/i2se/duckbill/iomux.c b/board/i2se/duckbill/iomux.c
-new file mode 100644
-index 0000000..538e138
--- /dev/null
+++ b/board/i2se/duckbill/iomux.c
@@ -0,0 +1,125 @@
@@ -378,9 +359,6 @@ index 0000000..538e138
+{
+ mxs_common_spl_init(arg, resptr, iomux_setup, ARRAY_SIZE(iomux_setup));
+}
-diff --git a/configs/duckbill_defconfig b/configs/duckbill_defconfig
-new file mode 100644
-index 0000000..2edf895
--- /dev/null
+++ b/configs/duckbill_defconfig
@@ -0,0 +1,9 @@
@@ -393,9 +371,6 @@ index 0000000..2edf895
+# CONFIG_SPI_FLASH is not set
+# CONFIG_CMD_FPGA is not set
+CONFIG_CMD_PING=y
-diff --git a/include/configs/duckbill.h b/include/configs/duckbill.h
-new file mode 100644
-index 0000000..46e403b
--- /dev/null
+++ b/include/configs/duckbill.h
@@ -0,0 +1,177 @@
@@ -576,6 +551,3 @@ index 0000000..46e403b
+#include <configs/mxs.h>
+
+#endif /* __CONFIGS_DUCKBILL_H__ */
---
-1.7.10.4
-
diff --git a/package/boot/uboot-mxs/patches/100-gcc-5-fix.patch b/package/boot/uboot-mxs/patches/100-gcc-5-fix.patch
new file mode 100644
index 0000000000..bec6ee72a6
--- /dev/null
+++ b/package/boot/uboot-mxs/patches/100-gcc-5-fix.patch
@@ -0,0 +1,11 @@
+--- a/arch/arm/cpu/arm926ejs/mxs/mxs.c
++++ b/arch/arm/cpu/arm926ejs/mxs/mxs.c
+@@ -24,7 +24,7 @@
+ DECLARE_GLOBAL_DATA_PTR;
+
+ /* Lowlevel init isn't used on i.MX28, so just have a dummy here */
+-inline void lowlevel_init(void) {}
++void lowlevel_init(void) {}
+
+ void reset_cpu(ulong ignored) __attribute__((noreturn));
+