summaryrefslogtreecommitdiffstats
path: root/package/boot/uboot-sunxi/Makefile
diff options
context:
space:
mode:
authorZoltan Herpai <wigyori@uid0.hu>2015-12-22 13:04:31 +0000
committerZoltan Herpai <wigyori@uid0.hu>2015-12-22 13:04:31 +0000
commit0f18228a3af47704813698a1fdf5f9ebd3e0242d (patch)
tree390d48731768aeb299615c2d746b3f3080c6251d /package/boot/uboot-sunxi/Makefile
parent2a0e1b7f8d59f795abb29d20007822f0da232c43 (diff)
downloadmaster-31e0f0ae-0f18228a3af47704813698a1fdf5f9ebd3e0242d.tar.gz
master-31e0f0ae-0f18228a3af47704813698a1fdf5f9ebd3e0242d.tar.bz2
master-31e0f0ae-0f18228a3af47704813698a1fdf5f9ebd3e0242d.zip
packages: bump uboot-sunxi to enable H3 support
Signed-off-by: Zoltan HERPAI <wigyori@uid0.hu> SVN-Revision: 47959
Diffstat (limited to 'package/boot/uboot-sunxi/Makefile')
-rw-r--r--package/boot/uboot-sunxi/Makefile14
1 files changed, 12 insertions, 2 deletions
diff --git a/package/boot/uboot-sunxi/Makefile b/package/boot/uboot-sunxi/Makefile
index b08f9ed1df..8471bb3cf4 100644
--- a/package/boot/uboot-sunxi/Makefile
+++ b/package/boot/uboot-sunxi/Makefile
@@ -9,13 +9,13 @@ include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/kernel.mk
PKG_NAME:=u-boot
-PKG_VERSION:=2015.07
+PKG_VERSION:=2016.01-rc2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:= \
http://mirror2.openwrt.org/sources \
ftp://ftp.denx.de/pub/u-boot
-PKG_MD5SUM:=3dac9a0b46fed77fc768ad3bd2d68c05
+PKG_MD5SUM:=aca6c7a38534812ab529e90aae976422
PKG_BUILD_DIR:=$(KERNEL_BUILD_DIR)/$(PKG_NAME)-$(BUILD_VARIANT)/$(PKG_NAME)-$(PKG_VERSION)
@@ -66,6 +66,10 @@ define uboot/Cubietruck
TITLE:=U-Boot for Cubietruck
endef
+define uboot/Hummingbird_A31
+ TITLE:=U-Boot for the Hummingbird A31 board
+endef
+
define uboot/Mele_M9
TITLE:=U-Boot for the Mele M9 (A31)
endef
@@ -86,6 +90,10 @@ define uboot/Lamobo_R1
TITLE:=U-Boot for Lamobo R1
endef
+define uboot/orangepi_plus
+ TITLE:=U-Boot for Orange Pi Plus (H3)
+endef
+
UBOOTS:= \
A10-OLinuXino-Lime \
A13-OLinuXino \
@@ -96,11 +104,13 @@ UBOOTS:= \
Cubieboard \
Cubieboard2 \
Cubietruck \
+ Hummingbird_A31 \
Mele_M9 \
OLIMEX_A13_SOM \
Linksprite_pcDuino \
Linksprite_pcDuino3 \
Lamobo_R1 \
+ orangepi_plus
define Package/uboot/template
define Package/uboot-sunxi-$(1)