summaryrefslogtreecommitdiffstats
path: root/package/boot/uboot-imx6/Makefile
diff options
context:
space:
mode:
authorLuka Perkov <luka@openwrt.org>2013-10-31 00:00:51 +0000
committerLuka Perkov <luka@openwrt.org>2013-10-31 00:00:51 +0000
commited676cf0ff108046b096388238559a0ef5c82ee6 (patch)
treee5393d97ab7c710915231c86c350620c649bd9a0 /package/boot/uboot-imx6/Makefile
parent672a8cd6ba72820f24a02dd237edaec3cd8973c5 (diff)
downloadmaster-31e0f0ae-ed676cf0ff108046b096388238559a0ef5c82ee6.tar.gz
master-31e0f0ae-ed676cf0ff108046b096388238559a0ef5c82ee6.tar.bz2
master-31e0f0ae-ed676cf0ff108046b096388238559a0ef5c82ee6.zip
uboot-imx6: update to 2013.10
Signed-off-by: Luka Perkov <luka@openwrt.org> SVN-Revision: 38625
Diffstat (limited to 'package/boot/uboot-imx6/Makefile')
-rw-r--r--package/boot/uboot-imx6/Makefile10
1 files changed, 4 insertions, 6 deletions
diff --git a/package/boot/uboot-imx6/Makefile b/package/boot/uboot-imx6/Makefile
index d2c6809960..0c989f3cfb 100644
--- a/package/boot/uboot-imx6/Makefile
+++ b/package/boot/uboot-imx6/Makefile
@@ -8,7 +8,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=u-boot
-PKG_VERSION:=2013.07
+PKG_VERSION:=2013.10
PKG_RELEASE:=1
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(BUILD_VARIANT)/$(PKG_NAME)-$(PKG_VERSION)
@@ -16,7 +16,7 @@ PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:= \
http://mirror2.openwrt.org/sources \
ftp://ftp.denx.de/pub/u-boot
-PKG_MD5SUM:=8445162690052e6afd4b8f87af2bb557
+PKG_MD5SUM:=a076a044b64371edc52f7e562b13f6b2
include $(INCLUDE_DIR)/package.mk
@@ -98,13 +98,11 @@ UBOOT_IMAGE:=$(if $(IMAGE),$(IMAGE),openwrt-$(BOARD)-$(BUILD_VARIANT)-u-boot.bin
endif
define Build/Configure
- $(MAKE) -C $(PKG_BUILD_DIR) \
- $(UBOOT_CONFIG)_config
+ $(MAKE) -C $(PKG_BUILD_DIR) $(UBOOT_CONFIG)_config
endef
define Build/Compile
- $(MAKE) -C $(PKG_BUILD_DIR) \
- CROSS_COMPILE=$(TARGET_CROSS)
+ $(MAKE) $(PKG_JOBS) -C $(PKG_BUILD_DIR) CROSS_COMPILE=$(TARGET_CROSS)
endef
define Package/uboot/install/default