summaryrefslogtreecommitdiffstats
path: root/package/boot/uboot-imx6/Makefile
diff options
context:
space:
mode:
authorLuka Perkov <luka@openwrt.org>2013-05-29 01:27:30 +0000
committerLuka Perkov <luka@openwrt.org>2013-05-29 01:27:30 +0000
commit5fbc56cfdc82ed6f7226217ad82fc3872c5ac3b3 (patch)
tree96a9adea4c6e25ba3bf45daf4db57063b2849d3b /package/boot/uboot-imx6/Makefile
parent4b21af426836d619f3251c90fc26475f6fee2fc5 (diff)
downloadmaster-31e0f0ae-5fbc56cfdc82ed6f7226217ad82fc3872c5ac3b3.tar.gz
master-31e0f0ae-5fbc56cfdc82ed6f7226217ad82fc3872c5ac3b3.tar.bz2
master-31e0f0ae-5fbc56cfdc82ed6f7226217ad82fc3872c5ac3b3.zip
uboot-imx6: add new package
SVN-Revision: 36754
Diffstat (limited to 'package/boot/uboot-imx6/Makefile')
-rw-r--r--package/boot/uboot-imx6/Makefile93
1 files changed, 93 insertions, 0 deletions
diff --git a/package/boot/uboot-imx6/Makefile b/package/boot/uboot-imx6/Makefile
new file mode 100644
index 0000000000..16465c78e2
--- /dev/null
+++ b/package/boot/uboot-imx6/Makefile
@@ -0,0 +1,93 @@
+#
+# Copyright (C) 2013 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=u-boot
+PKG_VERSION:=2013.04
+PKG_RELEASE:=1
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(BUILD_VARIANT)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_SOURCE_URL:=ftp://ftp.denx.de/pub/u-boot
+PKG_MD5SUM:=21bf962d69938ed4ed783b792b2b074e
+
+include $(INCLUDE_DIR)/package.mk
+
+define uboot/Default
+ TITLE:=
+ CONFIG:=
+ IMAGE:=
+endef
+
+define uboot/wandboard_solo
+ TITLE:=U-Boot for the Wandboard Solo
+endef
+
+define uboot/wandboard_dl
+ TITLE:=U-Boot for the Wandboard Dual Lite
+endef
+
+UBOOTS := \
+ wandboard_solo \
+ wandboard_dl
+
+define Package/uboot/template
+define Package/uboot-imx6-$(1)
+ SECTION:=boot
+ CATEGORY:=Boot Loaders
+ DEPENDS:=@TARGET_imx6
+ TITLE:=$(2)
+ URL:=http://www.denx.de/wiki/U-Boot
+ VARIANT:=$(1)
+ MAINTAINER:=Luka Perkov <luka@openwrt.org>
+endef
+endef
+
+define BuildUBootPackage
+ $(eval $(uboot/Default))
+ $(eval $(uboot/$(1)))
+ $(call Package/uboot/template,$(1),$(TITLE))
+endef
+
+ifdef BUILD_VARIANT
+$(eval $(call uboot/$(BUILD_VARIANT)))
+UBOOT_CONFIG:=$(if $(CONFIG),$(CONFIG),$(BUILD_VARIANT))
+UBOOT_IMAGE:=$(if $(IMAGE),$(IMAGE),openwrt-$(BOARD)-$(BUILD_VARIANT)-u-boot.bin)
+endif
+
+define Build/Configure
+ $(MAKE) -C $(PKG_BUILD_DIR) \
+ $(UBOOT_CONFIG)_config
+endef
+
+define Build/Compile
+ $(MAKE) -C $(PKG_BUILD_DIR) \
+ CROSS_COMPILE=$(TARGET_CROSS)
+endef
+
+define Package/uboot/install/default
+ $(INSTALL_DIR) $(BIN_DIR)/uboot-$(BOARD)-$(1)
+ $(CP) \
+ $(PKG_BUILD_DIR)/u-boot.imx \
+ $(BIN_DIR)/uboot-$(BOARD)-$(1)/openwrt-$(BOARD)-$(1)-u-boot.imx
+endef
+
+define Package/uboot/install/template
+define Package/uboot-imx6-$(1)/install
+ $(call Package/uboot/install/default,$(2))
+endef
+endef
+
+$(foreach u,$(UBOOTS), \
+ $(eval $(call Package/uboot/install/template,$(u),$(u))) \
+)
+
+$(foreach u,$(UBOOTS), \
+ $(eval $(call BuildUBootPackage,$(u))) \
+ $(eval $(call BuildPackage,uboot-imx6-$(u))) \
+)