summaryrefslogtreecommitdiffstats
path: root/package/boot/uboot-envtools
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-11-04 22:17:40 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-11-04 22:17:40 +0000
commitb8b4d363797192a416f08327753842550fd13ea3 (patch)
treed2f187d7030b85945c78e45a89b08c47c6edca45 /package/boot/uboot-envtools
parent12424634899c6dbee5e1358c4aaf30cc01e3f67e (diff)
downloadmaster-31e0f0ae-b8b4d363797192a416f08327753842550fd13ea3.tar.gz
master-31e0f0ae-b8b4d363797192a416f08327753842550fd13ea3.tar.bz2
master-31e0f0ae-b8b4d363797192a416f08327753842550fd13ea3.zip
uboot-envtools: fix various compile breakage issues
Signed-off-by: Felix Fietkau <nbd@openwrt.org> SVN-Revision: 47383
Diffstat (limited to 'package/boot/uboot-envtools')
-rw-r--r--package/boot/uboot-envtools/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/package/boot/uboot-envtools/Makefile b/package/boot/uboot-envtools/Makefile
index 54db0dd6c3..a5b0f92310 100644
--- a/package/boot/uboot-envtools/Makefile
+++ b/package/boot/uboot-envtools/Makefile
@@ -46,7 +46,7 @@ endef
define Build/Configure
touch $(PKG_BUILD_DIR)/include/config.mk
touch $(PKG_BUILD_DIR)/include/config.h
- mkdir $(PKG_BUILD_DIR)/include/generated
+ mkdir -p $(PKG_BUILD_DIR)/include/generated
touch $(PKG_BUILD_DIR)/include/generated/autoconf.h
endef
@@ -57,6 +57,8 @@ define Build/Compile
CROSS_COMPILE="$(TARGET_CROSS)" \
TARGET_CFLAGS="$(TARGET_CFLAGS)" \
UBI="$(CONFIG_UBOOT_ENVTOOLS_UBI)" \
+ dot-config=0 \
+ HOSTLDFLAGS= \
env
endef