summaryrefslogtreecommitdiffstats
path: root/package/boot/kexec-tools
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2013-06-28 11:27:13 +0000
committerFelix Fietkau <nbd@openwrt.org>2013-06-28 11:27:13 +0000
commitea5f9a7ba7e43df2a0b44a58003b85c501a5ca5f (patch)
treea89a166c6f6bdf53add7bff0fedb070b04a94be3 /package/boot/kexec-tools
parent6232a4300c9db189c824ef618b1d8799fe36d6b3 (diff)
downloadmaster-31e0f0ae-ea5f9a7ba7e43df2a0b44a58003b85c501a5ca5f.tar.gz
master-31e0f0ae-ea5f9a7ba7e43df2a0b44a58003b85c501a5ca5f.tar.bz2
master-31e0f0ae-ea5f9a7ba7e43df2a0b44a58003b85c501a5ca5f.zip
kexec-tools: make zlib support optional, but enabled by default
Signed-off-by: Felix Fietkau <nbd@openwrt.org> SVN-Revision: 37071
Diffstat (limited to 'package/boot/kexec-tools')
-rw-r--r--package/boot/kexec-tools/Config.in5
-rw-r--r--package/boot/kexec-tools/Makefile7
2 files changed, 10 insertions, 2 deletions
diff --git a/package/boot/kexec-tools/Config.in b/package/boot/kexec-tools/Config.in
index 60c819d798..2642171bb0 100644
--- a/package/boot/kexec-tools/Config.in
+++ b/package/boot/kexec-tools/Config.in
@@ -18,4 +18,9 @@ config KEXEC_TOOLS_kdump
help
Include the kdump utility.
+config KEXEC_ZLIB
+ bool
+ prompt "zlib support"
+ default y
+
endmenu
diff --git a/package/boot/kexec-tools/Makefile b/package/boot/kexec-tools/Makefile
index fa4f4d8efc..541dca275a 100644
--- a/package/boot/kexec-tools/Makefile
+++ b/package/boot/kexec-tools/Makefile
@@ -17,12 +17,14 @@ PKG_MD5SUM:=b3ced2097ce3981abba38ceedc84f939
PKG_FIXUP:=autoreconf
+PKG_CONFIG_DEPENDS := CONFIG_KEXEC_ZLIB
+
include $(INCLUDE_DIR)/package.mk
define Package/kexec-tools
SECTION:=utils
CATEGORY:=Utilities
- DEPENDS:=@armeb||@arm||@i386||@powerpc64||@mipsel||@mips +zlib
+ DEPENDS:=@armeb||@arm||@i386||@powerpc64||@mipsel||@mips +KEXEC_ZLIB:zlib
TITLE:=Kernel boots kernel
URL:=http://kernel.org/pub/linux/kernel/people/horms/kexec-tools/
MAINTAINER:=Florian Fainelli <florian@openwrt.org>
@@ -51,7 +53,8 @@ CONFIGURE_ARGS = \
--bindir=/usr/bin \
--sbindir=/usr/sbin \
--libexecdir=/usr/lib \
- --sysconfdir=/etc
+ --sysconfdir=/etc \
+ $(if $(CONFIG_KEXEC_ZLIB),--with,--without)-zlib
CONFIGURE_VARS += \
BUILD_CC="$(HOSTCC)" \