summaryrefslogtreecommitdiffstats
path: root/package/block-mount/Makefile
diff options
context:
space:
mode:
authorDaniel Dickinson <crazycshore@gmail.com>2011-04-05 12:12:57 +0000
committerDaniel Dickinson <crazycshore@gmail.com>2011-04-05 12:12:57 +0000
commitd5542b4f59cead42a4fa140deb7da74cc2750f20 (patch)
treef80d06d52ea577fab7469c2427b5e00706038925 /package/block-mount/Makefile
parentb62e95c11bef9eb0c1f1dd849c359a37a5568e13 (diff)
downloadmaster-31e0f0ae-d5542b4f59cead42a4fa140deb7da74cc2750f20.tar.gz
master-31e0f0ae-d5542b4f59cead42a4fa140deb7da74cc2750f20.tar.bz2
master-31e0f0ae-d5542b4f59cead42a4fa140deb7da74cc2750f20.zip
block-mount base-files: Added additional check to pi_include to ensure that a directory used with pi_include actually contains files matching the souring pattern because if not the shell dies due to an empty string in for statement. Added /lib/functions/fsck as an empty dir to block-mount. This combination fixes a warning which generates a lot of bug reports, without panicking the kernel like the last attempt.
SVN-Revision: 26479
Diffstat (limited to 'package/block-mount/Makefile')
-rw-r--r--package/block-mount/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/package/block-mount/Makefile b/package/block-mount/Makefile
index d2313f77f4..c2c9d33f13 100644
--- a/package/block-mount/Makefile
+++ b/package/block-mount/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=block-mount
PKG_VERSION:=0.2.0
-PKG_RELEASE:=4
+PKG_RELEASE:=5
include $(INCLUDE_DIR)/package.mk
@@ -50,7 +50,7 @@ define Package/block-mount/install
$(INSTALL_BIN) ./files/fstab.init $(1)/etc/init.d/fstab
$(INSTALL_DIR) $(1)/etc/config
$(INSTALL_DATA) ./files/fstab.config $(1)/etc/config/fstab
- $(INSTALL_DIR) $(1)/lib/functions
+ $(INSTALL_DIR) $(1)/lib/functions/fsck
$(INSTALL_DATA) ./files/mount.sh $(1)/lib/functions/
$(INSTALL_DATA) ./files/fsck.sh $(1)/lib/functions/
$(INSTALL_DATA) ./files/block.sh $(1)/lib/functions/