summaryrefslogtreecommitdiffstats
path: root/package/block-extroot/Makefile
diff options
context:
space:
mode:
authorDaniel Dickinson <crazycshore@gmail.com>2010-12-03 20:01:23 +0000
committerDaniel Dickinson <crazycshore@gmail.com>2010-12-03 20:01:23 +0000
commit68124370ac82720273db30b5706c227e60c1fa4d (patch)
tree890bb5ac1a4f6b94c1f75f243cbfee0354699f0d /package/block-extroot/Makefile
parent581378f5cb6ff8c0321f80f0750d9a7a09dfd63b (diff)
downloadmaster-31e0f0ae-68124370ac82720273db30b5706c227e60c1fa4d.tar.gz
master-31e0f0ae-68124370ac82720273db30b5706c227e60c1fa4d.tar.bz2
master-31e0f0ae-68124370ac82720273db30b5706c227e60c1fa4d.zip
block-extroot: Added md5sum to extroot and underlying root filesystem. This is used to ensure that the extroot is not mounted as the rootfs after a sysupgrade *until the user deals with the extroot).
SVN-Revision: 24230
Diffstat (limited to 'package/block-extroot/Makefile')
-rw-r--r--package/block-extroot/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/package/block-extroot/Makefile b/package/block-extroot/Makefile
index f1e093bcc3..05d5e18a1a 100644
--- a/package/block-extroot/Makefile
+++ b/package/block-extroot/Makefile
@@ -53,6 +53,7 @@ define Package/block-extroot/install
$(INSTALL_DATA) ./files/extmount.sh $(1)/lib/functions/
$(INSTALL_DIR) $(1)/lib/preinit
$(INSTALL_DATA) ./files/50_determine_usb_root $(1)/lib/preinit/
+ $(INSTALL_DATA) ./files/55_determine_extroot_sysupgrade $(1)/lib/preinit/
$(INSTALL_DATA) ./files/60_pivot_usb_root $(1)/lib/preinit/
$(INSTALL_DIR) $(1)/lib/preinit
echo "extroot_settle_time=\"$(CONFIG_EXTROOT_SETTLETIME)\"" >$(1)/lib/preinit/00_extroot.conf