summaryrefslogtreecommitdiffstats
path: root/package/base-files
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2016-07-26 08:14:14 +0200
committerFelix Fietkau <nbd@nbd.name>2016-07-26 08:26:24 +0200
commit5fd2eabeb27fc3d3b8d1c9fd1332c2229a6ff3d2 (patch)
tree4c969f34bd82d983d573ce58aad1dfcdc603c45c /package/base-files
parent776ca662614e559253f997462da8b96d5854faec (diff)
downloadmaster-31e0f0ae-5fd2eabeb27fc3d3b8d1c9fd1332c2229a6ff3d2.tar.gz
master-31e0f0ae-5fd2eabeb27fc3d3b8d1c9fd1332c2229a6ff3d2.tar.bz2
master-31e0f0ae-5fd2eabeb27fc3d3b8d1c9fd1332c2229a6ff3d2.zip
base-files: remove support of profile-specific base-files
It is incompatible with multi-profile builds and has not been used in-tree anyway. Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'package/base-files')
-rw-r--r--package/base-files/Makefile15
1 files changed, 0 insertions, 15 deletions
diff --git a/package/base-files/Makefile b/package/base-files/Makefile
index d036c92aa6..a32f345ea1 100644
--- a/package/base-files/Makefile
+++ b/package/base-files/Makefile
@@ -25,9 +25,6 @@ include $(INCLUDE_DIR)/package.mk
ifneq ($(DUMP),1)
STAMP_CONFIGURED:=$(strip $(STAMP_CONFIGURED))_$(shell $(SH_FUNC) echo $(CONFIG_TARGET_INIT_PATH) | md5s)
TARGET:=-$(BOARD)
- ifneq ($(wildcard $(PLATFORM_DIR)/base-files-$(PROFILE) $(PLATFORM_SUBDIR)/base-files-$(PROFILE)),)
- TARGET:=$(TARGET)-$(PROFILE)
- endif
endif
define Package/base-files
@@ -118,22 +115,10 @@ define Package/base-files/install
if [ -d $(PLATFORM_DIR)/base-files/. ]; then \
$(CP) $(PLATFORM_DIR)/base-files/* $(1)/; \
fi
- if [ -d $(PLATFORM_DIR)/base-files-$(PROFILE)/. ]; then \
- $(CP) $(PLATFORM_DIR)/base-files-$(PROFILE)/* $(1)/; \
- fi
- if [ -d $(PLATFORM_DIR)/$(PROFILE)/base-files/. ]; then \
- $(CP) $(PLATFORM_DIR)/$(PROFILE)/base-files/* $(1)/; \
- fi
$(if $(filter-out $(PLATFORM_DIR),$(PLATFORM_SUBDIR)), \
if [ -d $(PLATFORM_SUBDIR)/base-files/. ]; then \
$(CP) $(PLATFORM_SUBDIR)/base-files/* $(1)/; \
fi; \
- if [ -d $(PLATFORM_SUBDIR)/base-files-$(PROFILE)/. ]; then \
- $(CP) $(PLATFORM_SUBDIR)/base-files-$(PROFILE)/* $(1)/; \
- fi; \
- if [ -d $(PLATFORM_SUBDIR)/$(PROFILE)/base-files/. ]; then \
- $(CP) $(PLATFORM_SUBDIR)/$(PROFILE)/base-files/* $(1)/; \
- fi \
)
$(VERSION_SED) \