summaryrefslogtreecommitdiffstats
path: root/package/base-files
diff options
context:
space:
mode:
authorLuka Perkov <luka@openwrt.org>2014-01-23 11:33:41 +0000
committerLuka Perkov <luka@openwrt.org>2014-01-23 11:33:41 +0000
commitd66d2ad104751b30d5d09e3feac4e5dff12429b1 (patch)
treed7146a8e9d8a18807bc30ea289598fbc2b6e1146 /package/base-files
parent3787078b269d11a3251ffe5f9bc4d0adf8573af9 (diff)
downloadmaster-31e0f0ae-d66d2ad104751b30d5d09e3feac4e5dff12429b1.tar.gz
master-31e0f0ae-d66d2ad104751b30d5d09e3feac4e5dff12429b1.tar.bz2
master-31e0f0ae-d66d2ad104751b30d5d09e3feac4e5dff12429b1.zip
base-files: add ucidef_add_switch_port function
Signed-off-by: Luka Perkov <luka@openwrt.org> SVN-Revision: 39372
Diffstat (limited to 'package/base-files')
-rw-r--r--package/base-files/Makefile2
-rw-r--r--package/base-files/files/lib/functions/uci-defaults.sh10
2 files changed, 11 insertions, 1 deletions
diff --git a/package/base-files/Makefile b/package/base-files/Makefile
index d6c59384ee..33c0c5b24d 100644
--- a/package/base-files/Makefile
+++ b/package/base-files/Makefile
@@ -11,7 +11,7 @@ include $(INCLUDE_DIR)/kernel.mk
include $(INCLUDE_DIR)/version.mk
PKG_NAME:=base-files
-PKG_RELEASE:=150
+PKG_RELEASE:=151
PKG_FILE_DEPENDS:=$(PLATFORM_DIR)/ $(GENERIC_PLATFORM_DIR)/base-files/
PKG_BUILD_DEPENDS:=opkg/host
diff --git a/package/base-files/files/lib/functions/uci-defaults.sh b/package/base-files/files/lib/functions/uci-defaults.sh
index bf6fe1e305..da2093bbb7 100644
--- a/package/base-files/files/lib/functions/uci-defaults.sh
+++ b/package/base-files/files/lib/functions/uci-defaults.sh
@@ -234,3 +234,13 @@ set network.@switch_vlan[-1].ports='$ports'
EOF
}
+ucidef_add_switch_port() {
+ local device=$1
+ local port=$2
+ uci batch <<EOF
+add network switch_port
+set network.@switch_port[-1].device='$device'
+set network.@switch_port[-1].port='$port'
+EOF
+}
+