summaryrefslogtreecommitdiffstats
path: root/package/base-files
diff options
context:
space:
mode:
authorRod Whitby <rod@whitby.id.au>2007-09-21 13:20:50 +0000
committerRod Whitby <rod@whitby.id.au>2007-09-21 13:20:50 +0000
commitcd95009fc6727026f559cfdab5888727263ced1f (patch)
treee848b648924cfc178691e352b4028dc489985d33 /package/base-files
parent46e35b34813d1f4f053dbc3cb08b50932f919fb2 (diff)
downloadmaster-31e0f0ae-cd95009fc6727026f559cfdab5888727263ced1f.tar.gz
master-31e0f0ae-cd95009fc6727026f559cfdab5888727263ced1f.tar.bz2
master-31e0f0ae-cd95009fc6727026f559cfdab5888727263ced1f.zip
Added support for /etc/default/fstab - a means of automatically mounting devices on boot.
SVN-Revision: 8916
Diffstat (limited to 'package/base-files')
-rw-r--r--package/base-files/Makefile2
-rw-r--r--package/base-files/files/etc/config/fstab6
-rwxr-xr-xpackage/base-files/files/etc/init.d/fstab42
3 files changed, 49 insertions, 1 deletions
diff --git a/package/base-files/Makefile b/package/base-files/Makefile
index c639df8386..0cf96e2c86 100644
--- a/package/base-files/Makefile
+++ b/package/base-files/Makefile
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/kernel.mk
PKG_NAME:=base-files
-PKG_RELEASE:=10
+PKG_RELEASE:=11
PKG_FILE_DEPEND:=$(PLATFORM_DIR)/ $(GENERIC_PLATFORM_DIR)/base-files/
diff --git a/package/base-files/files/etc/config/fstab b/package/base-files/files/etc/config/fstab
new file mode 100644
index 0000000000..28bb705a49
--- /dev/null
+++ b/package/base-files/files/etc/config/fstab
@@ -0,0 +1,6 @@
+config mount
+ option target /home
+ option device /dev/sda1
+ option fstype ext3
+ option options rw,sync
+ option enabled 0
diff --git a/package/base-files/files/etc/init.d/fstab b/package/base-files/files/etc/init.d/fstab
new file mode 100755
index 0000000000..2a63a5b1bf
--- /dev/null
+++ b/package/base-files/files/etc/init.d/fstab
@@ -0,0 +1,42 @@
+#!/bin/sh /etc/rc.common
+# Copyright (C) 2007 OpenWrt.org
+
+START=20
+
+do_mount() {
+ local cfg="$1"
+ config_get fstype "$cfg" fstype
+ fstype="${fstype:-auto}"
+ config_get options "$cfg" options
+ options="${options:-rw}"
+ config_get device "$cfg" device
+ [ -n "device" ] || return 0
+ config_get target "$cfg" target
+ [ -n "target" ] || return 0
+ mkdir -p $target
+ config_get_bool enabled "$cfg" "enabled" '1'
+ [ "$enabled" -gt 0 ] && {
+ /bin/mount -t $fstype -o $options $device $target
+ }
+}
+
+do_unmount() {
+ local cfg="$1"
+ config_get target "$cfg" target
+ [ -n "target" ] || return 0
+ config_get_bool enabled "$cfg" "enabled" '1'
+ [ "$enabled" -gt 0 ] && {
+ /bin/umount $target
+ }
+}
+
+start() {
+ config_load fstab
+ config_foreach do_mount mount
+}
+
+stop() {
+ config_load fstab
+ config_foreach do_unmount mount
+}
+