summaryrefslogtreecommitdiffstats
path: root/package/base-files
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2011-05-08 10:25:58 +0000
committerJo-Philipp Wich <jow@openwrt.org>2011-05-08 10:25:58 +0000
commitba1c1e901615fd7cefc0966bbdd9d0d81581ae95 (patch)
tree2fd53b766baf1dd34bafa55593c374c85eac30f2 /package/base-files
parent732abc44ccb1641889ad7824bfc8aa6295e435f1 (diff)
downloadmaster-31e0f0ae-ba1c1e901615fd7cefc0966bbdd9d0d81581ae95.tar.gz
master-31e0f0ae-ba1c1e901615fd7cefc0966bbdd9d0d81581ae95.tar.bz2
master-31e0f0ae-ba1c1e901615fd7cefc0966bbdd9d0d81581ae95.zip
base-files: retrigger usb coldplug after module loading, solves usb_modeswitch on boot and possibly others (#9352)
SVN-Revision: 26848
Diffstat (limited to 'package/base-files')
-rw-r--r--package/base-files/Makefile2
-rwxr-xr-xpackage/base-files/files/etc/init.d/boot5
2 files changed, 6 insertions, 1 deletions
diff --git a/package/base-files/Makefile b/package/base-files/Makefile
index 95ab5a7c17..c10f483270 100644
--- a/package/base-files/Makefile
+++ b/package/base-files/Makefile
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/kernel.mk
PKG_NAME:=base-files
-PKG_RELEASE:=68
+PKG_RELEASE:=69
PKG_FILE_DEPENDS:=$(PLATFORM_DIR)/ $(GENERIC_PLATFORM_DIR)/base-files/
PKG_BUILD_DEPENDS:=opkg/host
diff --git a/package/base-files/files/etc/init.d/boot b/package/base-files/files/etc/init.d/boot
index c3019df04e..357ae3f31d 100755
--- a/package/base-files/files/etc/init.d/boot
+++ b/package/base-files/files/etc/init.d/boot
@@ -80,6 +80,11 @@ start() {
}
load_modules /etc/modules.d/*
+
+ # another round of USB coldplugging to kick devices into operation which lacked drivers before
+ for dev in /sys/bus/usb/devices/*/uevent; do
+ [ -e "$dev" ] && echo -n add > "$dev"
+ done
}
stop() {